ElmerGUI crashes each time I try to load mesh

The graphical user interface of Elmer
Post Reply
Gary R
Posts: 133
Joined: 12 Apr 2012, 07:23
Antispam: Yes
Location: Long Beach CA, USA

ElmerGUI crashes each time I try to load mesh

Post by Gary R »

Hi all,
Operating System: Debian GNU/Linux 11.
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.0-13-amd64
OS Type: 64-bit
Processors: 4 × AMD FX(tm)-4350 Quad-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: AMD CAICOS
Elmer version 9.0
Gmsh 4.7.1

Every time I try to set up a new project, the GUI crashes when I try to enter the mesh. The crash happens upon hitting the OK button just after I assign the mesh file. I have included a tar file for the whole project. Please note that the mesh needs to be refined another step to match the conditions that I used for the project. This problem has been happening with multiple projects. I downloaded a new copy of the source code from GitHub recently and completely rebuilt the program but the problem persists.

The workflow is FreeCAD -> Export .brep -> Gmsh -> ElmerGrid 14 2 -> ElmerGUI

Gary R.
Attachments
Tube_2mm.tar.gz
(48.45 KiB) Downloaded 24 times
kevinarden
Posts: 1417
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: ElmerGUI crashes each time I try to load mesh

Post by kevinarden »

It works with
ElmerGrid 14 2 Tube_2mm-Body.msh -autoclean

which removes the lower dimension bodies, i.e. you only get the solid and face elements

without autoclean it reports finding 792 edge elements even though there are only 48
Loading elmer mesh files
Summary:
Nodes: 311
Point elements: 2
Edge elements: 48
Surface elements: 528
Volume elements: 883
Found 792 edges on boundary
Segmentation fault (core dumped)
raback
Site Admin
Posts: 4345
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: ElmerGUI crashes each time I try to load mesh

Post by raback »

Hi

Opening directly of the .msh file with ElmerGUI might also work since then the autoclean is applied automatically.

-Peter
kevinarden
Posts: 1417
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: ElmerGUI crashes each time I try to load mesh

Post by kevinarden »

If I do it as a square tube ElmerGUI will read in the lower dimension elements without using autoclean flag
If I do it as a cylinder tube ElmerGUI will not read in the lower dimension elements, they have to be take out.
I used several different tools and formats for the cylinder same result.
tube.png
(46.38 KiB) Not downloaded yet
Gary R
Posts: 133
Joined: 12 Apr 2012, 07:23
Antispam: Yes
Location: Long Beach CA, USA

Re: ElmerGUI crashes each time I try to load mesh

Post by Gary R »

I tried loading the .msh file directly and it works. Wish I had known this a long time ago. This saves the whole ElmerGrid step and a lot of files.
Thanks
Gary R
Post Reply