missing: Python3_EXECUTABLE Python3_INCLUDE_DIRS When building with OCCT and VTK

Discussion about building and installing Elmer
raback
Site Admin
Posts: 4173
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: missing: Python3_EXECUTABLE Python3_INCLUDE_DIRS When building with OCCT and VTK

Post by raback »

Hi

ElmerGUI does not really need Python. The only reason to have this could be with the VTK widget as python can be used to do some scripting there. It should be turned off by default, but you could try with

Code: Select all

-DWITH_PYTHONQT:BOOL=FALSE 
Maybe version 9.0 of VTK tries to include python by default. If you use Paraview there is no need for VTK. Hence you could try to compile without.

-Peter
kevinarden
Posts: 1210
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: missing: Python3_EXECUTABLE Python3_INCLUDE_DIRS When building with OCCT and VTK

Post by kevinarden »

If that doesn't resolve you than you may try to make other options FALSE as a debugging approach. You could maybe make false OpenMP, MPI, PARAVIEW (paraview can be run separately) , not sure what the DOCE does or if opencascade us needed.

cmake -DWITH_OpenMP:BOOL=TRUE -DWITH_MPI:BOOL=TRUE -DWITH_QT5:BOOL=TRUE -DWITH_PARAVIEW:BOOL=TRUE -WITH_QWT:BOOL=TRUE -DWITH_VTK:BOOL=TRUE -DWITH_LUA:BOOL=TRUE -DWITH_MATC:BOOL=TRUE -DWITH_OCC=TRUE -DOCE_DIR=/usr/lib/cmake/opencascade -DWITH_ELMERGUI:BOOL=TRUE -DCMAKE_INSTALL_PREFIX=../install ../elmerfem
draena
Posts: 6
Joined: 18 May 2021, 12:34
Antispam: Yes

Re: missing: Python3_EXECUTABLE Python3_INCLUDE_DIRS When building with OCCT and VTK

Post by draena »

Thank you evryone for your answers, I was trying to build it with the following options:

Code: Select all

❯ cmake -DWITH_OpenMP:BOOL=TRUE -DWITH_MPI:BOOL=TRUE -DWITH_QT5:BOOL=TRUE -DWITH_PARAVIEW:BOOL=TRUE -WITH_QWT:BOOL=TRUE -DWITH_VTK:BOOL=FALSE -DWITH_PYTHONQT:BOOL=FALSE -DWITH_LUA:BOOL=TRUE -DWITH_MATC:BOOL=TRUE -DWITH_OCC=TRUE -DOCE_DIR=/usr/lib/cmake/opencascade -DWITH_ELMERGUI:BOOL=TRUE -DCMAKE_INSTALL_PREFIX=../install ../elmerfem -DPython3_EXECUTABLE=/usr/bin/python3 -DPython3_INCLUDE_DIRS=/usr/include/python3.9/
-- Checking whether GFortran version >= 4.8 -- yes
CMake Deprecation Warning at contrib/lua-5.1.5/CMakeLists.txt:2 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- Checking whether /usr/bin/gfortran supports OpenMP 4.0
-- Checking whether /usr/bin/gfortran supports OpenMP 4.0 -- yes
-- Checking whether /usr/bin/gfortran supports OpenMP 4.5
-- Checking whether /usr/bin/gfortran supports OpenMP 4.5 -- yes
CMake Deprecation Warning at cmake/Modules/FindMKL.cmake:2 (CMAKE_MINIMUM_REQUIRED):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.
Call Stack (most recent call first):
  CMakeLists.txt:302 (FIND_PACKAGE)


-- ------------------------------------------------
-- Mesh adaptation 2D/3D looking for [Mmg] tools 
CMake Deprecation Warning at cmake/Modules/FindMMG.cmake:14 (CMAKE_MINIMUM_REQUIRED):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.
Call Stack (most recent call first):
  CMakeLists.txt:367 (FIND_PACKAGE)


--   Library not found: >MMG_FOUND< 
--     Missing: >MMG_INCLUDE_DIR< , >MMG_LIBRARY<, to compile MMG3DSolver
-- ------------------------------------------------
-- Checking whether /usr/bin/gfortran supports PROCEDURE POINTER
-- Checking whether /usr/bin/gfortran supports PROCEDURE POINTER -- yes
-- Checking whether /usr/bin/gfortran supports CONTIGUOUS
-- Checking whether /usr/bin/gfortran supports CONTIGUOUS -- yes
-- Checking whether /usr/bin/gfortran supports EXECUTE_COMMAND_LINE
-- Checking whether /usr/bin/gfortran supports EXECUTE_COMMAND_LINE -- yes
-- Found 125 modules from /home/yamira/elmer/elmerfem/fem/src/modules
--  ELMERSOLVER_RPATH_STRING_MOD $ORIGIN/../lib/elmersolver
--  ELMERLIB_RPATH_STRING $ORIGIN/
CMake Deprecation Warning at fem/tests/CMakeLists.txt:2 (CMAKE_MINIMUM_REQUIRED):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- Skipping test PoissonDG with 16 procs
-- Skipping test WinkelPoissonMetisKwayDual with 16 procs
-- Skipping test WinkelPoissonMetisKwayNodal with 16 procs
-- Found 700 tests
CMake Deprecation Warning at elmergrid/CMakeLists.txt:1 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


CMake Deprecation Warning at elmergrid/src/metis-5.1.0/CMakeLists.txt:1 (cmake_minimum_required):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- checking for thread-local storage - found
--   Building ElmerGUI
-- ------------------------------------------------
CMake Deprecation Warning at ElmerGUI/CMakeLists.txt:1 (CMAKE_MINIMUM_REQUIRED):
  Compatibility with CMake < 2.8.12 will be removed from a future version of
  CMake.

  Update the VERSION argument <min> value or use a ...<max> suffix to tell
  CMake that the project does not need compatibility with older versions.


-- ------------------------------------------------
-- Qt5 non-Windows packaging
--   [ElmerGUI] Qt5:               
--   [ElmerGUI] Qt5 Libraries: Qt5::OpenGL Qt5::Xml Qt5::Script Qt5::Gui Qt5::Core
-- ------------------------------------------------
CMake Warning (dev) at /usr/share/cmake-3.20/Modules/FindOpenGL.cmake:315 (message):
  Policy CMP0072 is not set: FindOpenGL prefers GLVND by default when
  available.  Run "cmake --help-policy CMP0072" for policy details.  Use the
  cmake_policy command to set the policy and suppress this warning.

  FindOpenGL found both a legacy GL library:

    OPENGL_gl_LIBRARY: /usr/lib/libGL.so

  and GLVND libraries for OpenGL and GLX:

    OPENGL_opengl_LIBRARY: /usr/lib/libOpenGL.so
    OPENGL_glx_LIBRARY: /usr/lib/libGLX.so

  OpenGL_GL_PREFERENCE has not been set to "GLVND" or "LEGACY", so for
  compatibility with CMake 3.10 and below the legacy GL library will be used.
Call Stack (most recent call first):
  ElmerGUI/cmake/Modules/FindQwt.cmake:10 (INCLUDE)
  ElmerGUI/CMakeLists.txt:56 (FIND_PACKAGE)
This warning is for project developers.  Use -Wno-dev to suppress it.

CMake Warning (dev) at /usr/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:438 (message):
  The package name passed to `find_package_handle_standard_args` (OpenGL)
  does not match the name of the calling package (Qwt).  This can lead to
  problems in calling code that expects `find_package` result variables
  (e.g., `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
  /usr/share/cmake-3.20/Modules/FindOpenGL.cmake:443 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  ElmerGUI/cmake/Modules/FindQwt.cmake:10 (INCLUDE)
  ElmerGUI/CMakeLists.txt:56 (FIND_PACKAGE)
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Found OpenGL: /usr/lib/libOpenGL.so   
CMake Warning (dev) at /usr/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:438 (message):
  The package name passed to `find_package_handle_standard_args` (Qt3) does
  not match the name of the calling package (Qwt).  This can lead to problems
  in calling code that expects `find_package` result variables (e.g.,
  `_FOUND`) to follow a certain pattern.
Call Stack (most recent call first):
  /usr/share/cmake-3.20/Modules/FindQt3.cmake:213 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  /usr/share/cmake-3.20/Modules/FindQt.cmake:160 (include)
  ElmerGUI/cmake/Modules/FindQwt.cmake:11 (INCLUDE)
  ElmerGUI/CMakeLists.txt:56 (FIND_PACKAGE)
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Could NOT find Qt3 (missing: QT_QT_LIBRARY QT_INCLUDE_DIR) 
CMake was unable to find desired Qt version: 3. Set advanced values QT_QMAKE_EXECUTABLE and QT3_QGLOBAL_H_FILE.
--   [ElmerGUI] Qwt:             TRUE
--   [ElmerGUI] QWT_LIBRARY:     /usr/lib/libqwt.so
--   [ElmerGUI] QWT_INCLUDE_DIR: /usr/include/qwt
-- ------------------------------------------------
--   [ElmerGUI] OCE:               1
--   [ElmerGUI] OCE_VERSION:       
--   [ElmerGUI] OCE_INCLUDE_DIRS:  
--   [ElmerGUI] ELMER_OCC_LIBS:    TKernel;TKMath;TKG3d;TKG2d;TKBRep;TKSTEP;TKMesh;TKIGES;TKG2d;TKGeomBase;TKBool;TKBO;TKGeomAlgo;TKPrim;TKShHealing;TKSTEP209;TKSTEPAttr;TKSTEPBase;TKTopAlgo;TKXSBase
-- ------------------------------------------------
-- Found OpenGL: /usr/lib/libOpenGL.so  found components:  OpenGL GLX 
CMake Error at /usr/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:230 (message):
  Could NOT find Python3 (missing: Python3_INCLUDE_DIRS Development.Module)
Call Stack (most recent call first):
  /usr/share/cmake-3.20/Modules/FindPackageHandleStandardArgs.cmake:594 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.20/Modules/FindPython/Support.cmake:3165 (find_package_handle_standard_args)
  /usr/share/cmake-3.20/Modules/FindPython3.cmake:485 (include)
  /usr/lib64/cmake/vtk-9.0/VTK-vtk-module-find-packages.cmake:303 (find_package)
  /usr/lib64/cmake/vtk-9.0/vtk-config.cmake:131 (include)
  ElmerGUI/CMakeLists.txt:93 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
See also "/home/yamira/elmer/build/CMakeFiles/CMakeOutput.log".
See also "/home/yamira/elmer/build/CMakeFiles/CMakeError.log".
I need opencascade for operating with the STEP and be able to do the mesh.

Even though I try to make VTK false, the system insists in building elmerGUI with VTK. I even tried to specify the python paths.

Should I contact the Void developers for them to take a look at how VTK is built?


Thank you again for your answers.
Post Reply