Compile ElmerGUI under Windows 10 with VS

Discussion about building and installing Elmer
ceanwang
Posts: 14
Joined: 20 Mar 2021, 02:09
Antispam: Yes

Re: Compile ElmerGUI under Windows 10 with VS

Post by ceanwang »

kevinarden wrote: 30 Mar 2021, 12:17 According to the documentation you have to have at least QT5.4 version.
https://github.com/FreeCAD/FreeCAD/releases/tag/0.19.1

FreeCADLibs_12.5.3_VC1.7 updates QT 5.15.1.

I am using 12.5.1, its QT should be higher than 5.4
Last edited by ceanwang on 31 Mar 2021, 05:54, edited 1 time in total.
ceanwang
Posts: 14
Joined: 20 Mar 2021, 02:09
Antispam: Yes

Re: Compile ElmerGUI under Windows 10 with VS

Post by ceanwang »

raback wrote: 30 Mar 2021, 16:39 HI, Maybe you could drop "VTK" if that is problematic. Most people use Paraview anyways. -Peter
I just want to use vtkPost to see why it can't read my ascii vtu file.

I build vtk8.2 by myself with Module_vtkGUISupportQtOpenGl, Module_vtkGUISupportQt and Module_vtkGUISupportMFC ticked.

and copied them into FreeCADlibs.

After a few small tweaks, the main error now is:

Code: Select all

Severity	Code	Description	Project	File	Line	Suppression State
Error	LNK2019	unresolved external symbol "__declspec(dllimport) public: static class QSurfaceFormat __cdecl QVTKOpenGLNativeWidget::defaultFormat(void)" (__imp_?defaultFormat@QVTKOpenGLNativeWidget@@SA?AVQSurfaceFormat@@XZ) referenced in function "public: __cdecl VtkPost::VtkPost(class QWidget *)" (??0VtkPost@@QEAA@PEAVQWidget@@@Z)	ElmerGUI	D:\00master\elmerfem-devel\ElmerGUI\build_vs\Application\vtkpost.obj	1	
Searching the net, It seems I have to build VTK with the same setting with FreeCADlibs's QT.
Post Reply