No convergence followed by "NaN" relative change

Numerical methods and mathematical models of Elmer
Post Reply
Captain Slow
Posts: 72
Joined: 10 Nov 2009, 19:17

No convergence followed by "NaN" relative change

Post by Captain Slow »

Hi there,

Running my simulation today I have experienced some strange behaviour. For the first 8 interations the relative change decreases quite nicely, but then I observe relative changes of ~2 for the next 20 iterations. But then, most strangely, this is observed:

FlowSolve: iter: 35 Assembly: (s) 4.72 164.06
FlowSolve: iter: 35 Solve: (s) 123.33 2696.38
ComputeChange: NS (ITER=35) (NRM,RELC): ( +Infinity NaN ) :: navier-stokes
FlowSolve: Result Norm : +Infinity
FlowSolve: Relative Change : NaN
FlowSolve: -------------------------------------
FlowSolve: -------------------------------------
FlowSolve: Starting Assembly...

FlowSolve: Assembly done

FlowSolve: Dirichlet conditions done

The simulation "freezes" at this point-no more iterations are attempted, but the message saying that elmersolver has finished is not displayed, nor is any output file produced.

I attach the sif file.

The strange thing is that I ran this simulation with the same geometry, inputs etc with a coarser mesh and it worked absolutely fine. Maybe the problem is that I run out of computing power because the mesh is too fine?

I had a similar thing happen with a different geometry/conditions a few weeks ago, however the simulation continued with a series of iterations with relative change "NaN" untill the Max. number of iterations limit is reached.
(3.31 KiB) Downloaded 203 times
Post Reply