ElmerGUI compilation

Discussion about building and installing Elmer
Post Reply
annier
Posts: 1157
Joined: 27 Aug 2013, 13:51
Antispam: Yes

ElmerGUI compilation

Post by annier »

Hi,
when i try to load ElmerGUI. the following warnings are seen:
Initialization File does not exist
Material library does not exist
Definition file does not exist
what should i do to solve this matter?
thanking you in advance
annier
Last edited by annier on 11 Oct 2013, 17:34, edited 1 time in total.
Anil Kunwar
Faculty of Mechanical Engineering, Silesian University of Technology, Gliwice
annier
Posts: 1157
Joined: 27 Aug 2013, 13:51
Antispam: Yes

Re: ElmerGUI compilation

Post by annier »

Although i am still to solve this matter, i have got the hint of using ElmerGUItester.
viewtopic.php?f=2&t=49
After reading the post, i launched the ElmerGUI tester and found that Elmer was incorrectly installed in my computer.
Thank you Mikko for the post.
Anil Kunwar
Faculty of Mechanical Engineering, Silesian University of Technology, Gliwice
annier
Posts: 1157
Joined: 27 Aug 2013, 13:51
Antispam: Yes

Re: ElmerGUI compilation

Post by annier »

Now, I could compile the Elmer software in my home directory. i would like to thank the authors of the following posts for their valuable guidelines
http://ascend4.org/Building_Elmer_on_Ubuntu_12.04
http://www.cfd-online.com/Forums/main/6 ... linux.html
Also, i would like to thank Mikko for highlighting the importance of setting environment variables (viewtopic.php?f=2&t=49).
Anil Kunwar
Faculty of Mechanical Engineering, Silesian University of Technology, Gliwice
jeroenr
Posts: 20
Joined: 16 Oct 2013, 21:41
Antispam: Yes

Re: ElmerGUI compilation

Post by jeroenr »

I can't seem to build ElmerGui on Slackware64 14.0. The link http://ascend4.org/Building_Elmer_on_Ubuntu_12.04 was pretty helpfull in changing the location for qwt in the ElmerGUI.pri file. I've also disabled VTK by commenting out the line. But I can't fix the issue with OpenCASCADE. Version 6.3 which was successfully used to build ElmerGui, is not available for download anymore. The oldest version currently downloadable is OpenCASCADE 6.5.1. At the moment I have version 6.5.2 installed. I get the following errors when I try to build ElmerGui:

Code: Select all

In file included from /usr/include/OpenCASCADE/Standard_OStream.hxx:8:0,
                 from /usr/include/OpenCASCADE/Standard_ExtCharacter.hxx:24,
                 from /usr/include/OpenCASCADE/Standard_PrimitiveTypes.hxx:29,
                 from /usr/include/OpenCASCADE/Handle_Standard_Transient.hxx:10,
                 from /usr/include/OpenCASCADE/Handle_MMgt_TShared.hxx:17,
                 from /usr/include/OpenCASCADE/Handle_TopoDS_TShape.hxx:17,
                 from /usr/include/OpenCASCADE/TopoDS_Shape.hxx:17,
                 from ./cad/cadview.h:53,
                 from src/mainwindow.h:78,
                 from src/bodypropertyeditor.cpp:43:
/usr/include/OpenCASCADE/Standard_Stream.hxx:84:12: error: 'std::setw' has not been declared
/usr/include/OpenCASCADE/Standard_Stream.hxx:85:12: error: 'std::setprecision' has not been declared
make[1]: *** [tmp/bodypropertyeditor.o] Error 1
make[1]: Leaving directory `/home/jeroen/downloads/elmerfem/ElmerGUI/Application'
make: *** [sub-Application-make_default] Error 2
Has anyone run into the same problem and found a solution? Or maybe just some pointers on how to begin to fix this ...

I'm already running Elmer on a Windows laptop and I wish to run it from my Linux desktop aswell.
annier
Posts: 1157
Joined: 27 Aug 2013, 13:51
Antispam: Yes

Re: ElmerGUI compilation

Post by annier »

Hi,
i cannot say how you can solve it.
have you tried with the option of replacing the ElmerGUI of your installation version with the ElmerGUI of a newer or older Elmer version and again compile it? this is not an innovative idea however. you need to use this if no any other option works. since there may be a chance of mismatch of compatibility of Elmer components.
yours
annier
Anil Kunwar
Faculty of Mechanical Engineering, Silesian University of Technology, Gliwice
thamel
Posts: 1
Joined: 10 Jan 2014, 20:43
Antispam: Yes

Re: ElmerGUI compilation

Post by thamel »

jeroenr wrote:

Code: Select all

/usr/include/OpenCASCADE/Standard_Stream.hxx:84:12: error: 'std::setw' has not been declared
/usr/include/OpenCASCADE/Standard_Stream.hxx:85:12: error: 'std::setprecision' has not been declared
make[1]: *** [tmp/bodypropertyeditor.o] Error 1
make[1]: Leaving directory `/home/jeroen/downloads/elmerfem/ElmerGUI/Application'
make: *** [sub-Application-make_default] Error 2
Has anyone run into the same problem and found a solution? Or maybe just some pointers on how to begin to fix this ...
I fixed that with a patch (OpenCascade 6.7.0):

Code: Select all

Index: ElmerGUI/Application/cad/cadview.h
===================================================================
--- ElmerGUI/Application/cad/cadview.h	(revision 6494)
+++ ElmerGUI/Application/cad/cadview.h	(working copy)
@@ -50,6 +50,7 @@
 #include "nglib.h"
 }
 
+#include <iomanip>
 #include <TopoDS_Shape.hxx>
 
 class QMenu;
The patch must have DOS style end of lines to be used as-is, if you edit manually your text editor should handle that.
foadsf
Posts: 70
Joined: 20 Sep 2016, 23:56
Antispam: Yes
Contact:

Re: ElmerGUI compilation

Post by foadsf »

For those of you running to this problem on Windows OS, I wrote a small cmd/batch script a while ago. A wrong version of it has been uploaded to the Elmer repository. Please find the correct one in the attachments of this post.
Attachments
RunElmer.zip
(267 Bytes) Downloaded 28 times
raback
Site Admin
Posts: 4282
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: ElmerGUI compilation

Post by raback »

Thanx foad! I just uploaded this to nic.funet.fi as well.
Post Reply