netgen errors

Mesh generators, CAD programs, and other tools
Post Reply
Gary R
Posts: 60
Joined: 12 Apr 2012, 07:23
Antispam: Yes
Location: Long Beach CA

netgen errors

Post by Gary R » 28 Oct 2017, 02:59

Netgen seems to be in a real mess in Debian and Ubuntu. I tried to install the standard Ubuntu package (4.9.13). When run, I get the following errors:

Code: Select all

Parsing ng.tcl
optfile ./ng.opt does not exist - using default values
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  3 (X_GLXCreateContext)
  Value in failed request:  0x0
  Serial number of failed request:  484
  Current serial number in output stream:  485
I tried to install from source code but make would not finish giving the following errors:

Code: Select all

/usr/lib/gcc/x86_64-linux-gnu/6/../../../../lib/libTogl.so: undefined reference to `Tk_InitStubs'
/usr/lib/gcc/x86_64-linux-gnu/6/../../../../lib/libTogl.so: undefined reference to `tkStubsPtr'
/usr/lib/gcc/x86_64-linux-gnu/6/../../../../lib/libTogl.so: undefined reference to `Tcl_InitStubs'
/usr/lib/gcc/x86_64-linux-gnu/6/../../../../lib/libTogl.so: undefined reference to `tclStubsPtr'
collect2: error: ld returned 1 exit status
Is there any way to correct these to get a working copy.

Kubuntu17.04 OS

Gary R

Gary R
Posts: 60
Joined: 12 Apr 2012, 07:23
Antispam: Yes
Location: Long Beach CA

Re: netgen errors

Post by Gary R » 03 Nov 2017, 21:38

Update:
Debian unstable has a version of netgen-4.9.13 that works. Why doesn't the Ubuntu version work? How can I fix this? This is really hanging up my progress with Elimer. Somebody pleeese help.

Gary R.

mzenker
Posts: 1729
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: netgen errors

Post by mzenker » 06 Nov 2017, 15:31

Hi,

you might try to install the workung netgen package from debian using flatpak (flatpak.org), AppImage (appimage.org) or Snap (https://www.ubuntu.com/desktop/snappy), which seem to provide a kind of runtime enviromnent for packages having their own dependencies not compatible with the current Linux distribution. I have not used them, just heard of them. But maybe it helps here?

Matthias

Gary R
Posts: 60
Joined: 12 Apr 2012, 07:23
Antispam: Yes
Location: Long Beach CA

Re: netgen errors

Post by Gary R » 10 Nov 2017, 06:11

Another update:
I finally downloaded the source code for github for netgen. I had the usual problems with getting the proper libraries and such installed but finally got a good make run. Unfortunately, when I ran make install I got the following error:

file INSTALL cannot find "/usr/include/../LICENSE"

It seems that the installer is looking in the wrong place for the license. The license is in usr/local/share/netgen/.git/netgen-master/

How do I fix this?

Gary R

Post Reply