Help with import of mesh-files from the format .unv

Mesh generators, CAD programs, and other tools
Daniel
Posts: 11
Joined: 03 Dec 2009, 12:23

Help with import of mesh-files from the format .unv

Post by Daniel » 03 Dec 2009, 13:01

Hi there,
I'm really new to elmer and with it to elmergrid.
I'm using an external Preprocessor that outputs several output-formats like ansys, abaqus or Ideas-V (.unv)
I tried everything (I think) to get may .unv-file into the .mesh.*
As I understood the command line parameters of elmergrid- I have to type

elmergrid 8 2 test.unv

to translate my .unv-file to .mesh.* so I can use my mesh with elmer.
But the only output I get from elmergrid is:
Starting program Elmergrid
Elmergrid reading in-line arguments
Output will be saved to file Wuerfel.

Elmergrid loading data:
Reading mesh from universal mesh file Wuerfel.unv.
done reading
Invalid mesh consits of 0 knots and 0 0-node elements.

Thank you for using Elmergrid!
Send bug reports and feature wishes to peter.raback@csc.fi
Do you know that kind of problem? The .unv-File is attached to this post.
Wuerfel.unv
(189.77 KiB) Downloaded 169 times
As far as I can judge it, the .unv -file should work.
I also tried to read in ansys files or abaqus files, but always with the same result

Thank you very much fpr every kind of help!

Daniel

raback
Site Admin
Posts: 3264
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: Help with import of mesh-files from the format .unv

Post by raback » 03 Dec 2009, 23:57

It seems that the ElmerGrid parser has some bug. This was reported in some other mail also. I'll study the problem when I've some spare time. Is the same bug happening when you open the .unv file through ElmerGUI. Perhaps you could specify your ElmerSolver version (that will help to date also ElmerGrid). Thank you for reporting.

-Peter

mzenker
Posts: 1741
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Help with import of mesh-files from the format .unv

Post by mzenker » 17 Mar 2011, 13:01

Hi,

I have a similar problem, Elmer won't read an .inp file, claiming there are 0 nodes.
I have also reproduced Daniel's problem using his Wuerfel.unv file.
My Elmer is Reversion 5043, WIN XP.
A bugfix here would be great...

Thank you,

Matthias

raback
Site Admin
Posts: 3264
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: Help with import of mesh-files from the format .unv

Post by raback » 17 Mar 2011, 16:47

Hi

It seems this was forgetten. The universal file format seems all but universal to me. ElmerGrid can handle fields 2411, 2412, 2435 and 2467. The example includes fields 780 and 781. The 781 seems to be rather standard node definitions. However 780 seems more complicated including the topology definition in rather strange format. Could anybody sent a picture how the mesh should look like, or even better have definition somewhere available for the field 780?

-Peter

mzenker
Posts: 1741
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Help with import of mesh-files from the format .unv

Post by mzenker » 17 Mar 2011, 17:03

Hi Peter,

thank you for looking into this issue.
I will try to provide you a simplified test case for my inp problem tomorrow. As for the "Wuerfel.unp", I don't have the original geometry data either.

Thank you,

Matthias

mzenker
Posts: 1741
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Help with import of mesh-files from the format .unv

Post by mzenker » 18 Mar 2011, 12:08

Hi Peter,

here is a simple inp file which ElmerGUI opens, but nothing is displayed. The log window says:

Code: Select all

The mesh was loaded from file H:\[...]\Baugruppe1-Studie 1.inp.
Boundary types are in interval [227652648, 227652648]
Boundary nodes are in interval [227328504, 227328504]
Found 0 side elements formed by 0 points.

ElmerGrid manipulating and importing data
GetElementDimension: unknown elementtype 0
Setting elements of 0dim
Implemented only for element dimensions 2 and 3 (not 0)
Done converting mesh
Found 0 edges on boundary
Creating edge indexes 
0 boundary edges were numbered up to index 0
Bcs/materials on surface elements: 0
Bcs/materials on edge elements: 0
Bcs/materials on point elements: 0
Generating  lists to display
Generated 2 lists
Apply 0 operations
The file is appended to this message.
It was produced by Solidworks and meshed by CosmosWorks.

I hope the bug is easy to find and fix... ;)

Thank you,

Matthias
Attachments
Baugruppe1-Studie 1.zip
(205.52 KiB) Downloaded 128 times

raback
Site Admin
Posts: 3264
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: Help with import of mesh-files from the format .unv

Post by raback » 18 Mar 2011, 13:50

Hi

The initial unv example Wuerfel.unv seems now to work with the current svn version (the definition is missing bulk elements though). I added fields 780 and 781 to the parser as defined in http://www.sdrl.uc.edu/universal-file-f ... storehouse.

-Peter

raback
Site Admin
Posts: 3264
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: Help with import of mesh-files from the format .unv

Post by raback » 18 Mar 2011, 14:15

Matthias, I only had a brief look at the .inp file. Unfortunately I don't have time now to dwell deeper into it. However, just a visual inspection reveals that only nodes are specified in there and element definitions are missing. Hence there is no way to create any proper FE mesh from this example. -Peter

mzenker
Posts: 1741
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Help with import of mesh-files from the format .unv

Post by mzenker » 18 Mar 2011, 14:22

Hi Peter,

thank you for looking into it.
Since this is the first time we use CosmosWorks for meshing, we may well have made a mistake using it.
I will check the file next week, try to produce a valid one and post it here.

Matthias

elgrip
Posts: 9
Joined: 30 Nov 2011, 07:06
Antispam: Yes

Re: Help with import of mesh-files from the format .unv

Post by elgrip » 03 Jan 2012, 19:00

Quadratic mesh import trouble ... I also have been having trouble importing .unv files into Elmer, from Salome. The regular tetrahedral and hexahedral meshes import into Elmer correctly. However no quadratic mesh will import; Elmer GUI crashes every time. I am using Windows 7 for all of this. Has anyone a workaround for this?

Post Reply