Problem with loading GMSH generated mesh to ElmerGUI

Mesh generators, CAD programs, and other tools

Problem with loading GMSH generated mesh to ElmerGUI

Postby Estiivan » 29 Dec 2016, 13:08

Hello,

I have a very simple square geometry defined in GMSH as

Code: Select all
//+
Point(1) = {-3, 3, 0, 1.0};
//+
Point(2) = {-3, -3, 0, 1.0};
//+
Point(3) = {3, -3, 0, 1.0};
//+
Point(4) = {3, 3, 0, 1.0};
//+
Line(1) = {1, 2};
//+
Line(2) = {2, 3};
//+
Line(3) = {3, 4};
//+
Line(4) = {4, 1};
//+
Line Loop(5) = {1, 2, 3, 4};
//+
Plane Surface(6) = {5};


You can see the mesh in picture attached, in the upper part. However, when I try to load corresponding mesh to ElmerGUI, it looks very odd. See the bottom part of the picture. What goes wrong? I include msh file as well.

Screenshot from 2016-12-29 11-58-54.png
GMSH generated mesh as seen in GMSH and in ElmerGUI
(93.79 KiB) Not downloaded yet

untitled.msh
GMSH generated msh file
(4.81 KiB) Downloaded 8 times


With regards,
Estiivan
Estiivan
 
Posts: 25
Joined: 14 Nov 2016, 14:06

Re: Problem with loading GMSH generated mesh to ElmerGUI

Postby Estiivan » 30 Dec 2016, 10:31

Hello all,

problem went away by using command 'ElmerGrid 14 2 name.msh'. So I guess GMSH meshes have to be transformed to Elmer format first (although some tutorial suggested that this might not be necessary).

BR,
Estiivan
Estiivan
 
Posts: 25
Joined: 14 Nov 2016, 14:06


Return to External tools

Who is online

Users browsing this forum: No registered users and 1 guest