ugly mesh and remesh doesn't work

The graphical user interface of Elmer
Post Reply
wing
Posts: 10
Joined: 14 Oct 2009, 11:49

ugly mesh and remesh doesn't work

Post by wing » 14 Oct 2009, 18:19

Hi there,
I compiled the latest version (revision 4259) from svn at Ubuntu 9.10. I import a .stp geometry to ElmerGUI for auto meshing but the result looks ugly, the mesh fineness is low. I tried to change Max.H and Fineness at the nglib item from Mesh --> Configure.. and remesh, but nothing happened.
I have another older svn revision (don't have the ver. number, just the date, 2009-5-17) at Ubuntu 8.04 and it seems OK for the same .stp. (the mesh is fine enough after the geometry imported).
Btw, elmerparam is not installed in my Ubuntu9.10 because I got a compilation error which not resolved yet. Could this be the cause?

Thanks and best regards,
wing
Attachments
mesh at old revision, Ubuntu 8.04
mesh at old revision, Ubuntu 8.04
mesh - ElmerGUI Ubuntu8.04.png (71.79 KiB) Viewed 2737 times
mesh at latest revision, Ubuntu 9.10
mesh at latest revision, Ubuntu 9.10
mesh - ElmerGUI Ubuntu9.10.png (34.49 KiB) Viewed 2737 times

mal
Site Admin
Posts: 54
Joined: 21 Aug 2009, 14:21

Re: ugly mesh and remesh doesn't work

Post by mal » 14 Oct 2009, 18:39

There was a small change... Could you please try the following:

- In the main window, choose View -> Cad model...
- In the cad model window, choose Model -> Preferences...
- Check "Restrict mesh size on surfaces by STL density"
- In the main window, open your stp file

wing
Posts: 10
Joined: 14 Oct 2009, 11:49

Re: ugly mesh and remesh doesn't work

Post by wing » 18 Oct 2009, 11:51

Hi mal,

Thanks for your response. It works for me.

dan
Posts: 1
Joined: 01 Mar 2019, 15:28
Antispam: Yes

Re: ugly mesh and remesh doesn't work

Post by dan » 01 Mar 2019, 15:36

Hi,
I'm following the " Tutorial 1 Heat equation – Temperature field of a solid object " and after open "pump_carter_sup.stp" and getting the mesh I have a problem when I try to modify the mesh by altering the settings as it is explained " View -> Cad model...; Model -> Preferences... ":
When I click on "View -> Cad model... " a window called Elmer GUI geometry viewer is opened. I try all kinds of clicking and nothing happens in that window.
I don't know if something is wrong with my installation or if I should look for that option in other place.
Thanks for reading

kevinarden
Posts: 256
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: ugly mesh and remesh doesn't work

Post by kevinarden » 01 Mar 2019, 17:42

It works in my installation.

Kevin

kevinarden
Posts: 256
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: ugly mesh and remesh doesn't work

Post by kevinarden » 01 Mar 2019, 23:00

There is a Linux Mint based virtual machine (VM) available at
http://www.nic.funet.fi/pub/sci/physics ... alMachines

The VM is huge in size but provides a certified user experience. This is often used at courses to give not only a fresh Elmer version, but also a complete installation of related tools.

There is also a CAELINUX.iso that can be on a virtual machine or livecd that includes Elmer. You could use either to see if it works in another environment.

Post Reply