error runing my first model

The graphical user interface of Elmer
Post Reply
pete2
Posts: 5
Joined: 13 Jul 2018, 17:25
Antispam: Yes

error runing my first model

Post by pete2 » 13 Jul 2018, 17:33

hi everyone,

I am new using elmer. I got this error when i run the model

Code: Select all

ELMER SOLVER (v 8.2) STARTED AT: 2018/07/13 14:56:58
ParCommInit:  Initialize #PEs:            1
MAIN: 
MAIN: =============================================================
MAIN: ElmerSolver finite element software, Welcome!
MAIN: This program is free software licensed under (L)GPL
MAIN: Copyright 1st April 1995 - , CSC - IT Center for Science Ltd.
MAIN: Webpage http://www.csc.fi/elmer, Email elmeradm@csc.fi
MAIN: Version: 8.2 (Rev: Release, Compiled: 2016-03-15)
MAIN: =============================================================

MAIN: 
MAIN: 
MAIN: -------------------------------------
MAIN: Reading Model: case.sif
Loading user function library: [StatElecSolve]...[StatElecSolver_Init0]
LoadMesh: Base mesh name: ./.

LoadMesh: Elapsed time (CPU,REAL):     0.8270    0.8270 (s)
MAIN: -------------------------------------
Loading user function library: [StatElecSolve]...[StatElecSolver_Init]
Loading user function library: [StatElecSolve]...[StatElecSolver]
OptimizeBandwidth: ---------------------------------------------------------
OptimizeBandwidth: Computing matrix structure for: electrostatics...done.
OptimizeBandwidth: Half bandwidth without optimization: 178
OptimizeBandwidth: 
OptimizeBandwidth: Bandwidth Optimization ...done.
OptimizeBandwidth: Half bandwidth after optimization: 35
OptimizeBandwidth: ---------------------------------------------------------
MAIN: 
MAIN: -------------------------------------
MAIN:  Steady state iteration:            1
MAIN: -------------------------------------
MAIN: 
SingleSolver: Attempting to call solver
SingleSolver: Solver Equation string is: electrostatics
StatElecSolve: -------------------------------------
StatElecSolve: STATELEC SOLVER:
StatElecSolve: -------------------------------------
StatElecSolve: 
StatElecSolve: Electrostatic iteration: 1
StatElecSolve: Starting Assembly...
WARNING:: ListFind: 
WARNING:: ListFind:  Requested property: [Material], not found
WARNING:: ListFind: 


Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0  ffffffffffffffff
I am trying to do a electrostatic simulation with just 1 body. it says Material not found, but I add air as a material and I clicked the box for body 1, which is the only body in the simulation.

thanks!

KaiMartin
Posts: 34
Joined: 02 Jun 2013, 00:07
Antispam: Yes
Location: Hannover, Germany
Contact:

Re: error runing my first model

Post by KaiMartin » 15 Jul 2018, 07:07

Can you post the *.sif file? This is a compilation of the settings you did in the GUI. It is used an input for the solver.

---<)kaimartin(>---
---<)kaimartin(>---

pete2
Posts: 5
Joined: 13 Jul 2018, 17:25
Antispam: Yes

Re: error runing my first model

Post by pete2 » 16 Jul 2018, 15:01

thank you
this is the .sif file

Code: Select all

Header
  CHECK KEYWORDS Warn
  Mesh DB "." "."
  Include Path ""
  Results Directory ""
End

Simulation
  Max Output Level = 5
  Coordinate System = Cartesian
  Coordinate Mapping(3) = 1 2 3
  Simulation Type = Steady state
  Steady State Max Iterations = 1
  Output Intervals = 1
  Timestepping Method = BDF
  BDF Order = 1
  Solver Input File = case.sif
  Post File = case.ep
End

Constants
  Gravity(4) = 0 -1 0 9.82
  Stefan Boltzmann = 5.67e-08
  Permittivity of Vacuum = 8.8542e-12
  Boltzmann Constant = 1.3807e-23
  Unit Charge = 1.602e-19
End

Body 1
  Target Bodies(1) = 1
  Name = "Body 1"
  Equation = 1
  Initial condition = 1
End

Solver 1
  Equation = Electrostatics
  Variable = Potential
  Procedure = "StatElecSolve" "StatElecSolver"
  Exec Solver = Always
  Stabilize = True
  Bubbles = False
  Lumped Mass Matrix = False
  Optimize Bandwidth = True
  Steady State Convergence Tolerance = 1.0e-5
  Nonlinear System Convergence Tolerance = 1.0e-7
  Nonlinear System Max Iterations = 20
  Nonlinear System Newton After Iterations = 3
  Nonlinear System Newton After Tolerance = 1.0e-3
  Nonlinear System Relaxation Factor = 1
  Linear System Solver = Iterative
  Linear System Iterative Method = BiCGStab
  Linear System Max Iterations = 500
  Linear System Convergence Tolerance = 1.0e-10
  BiCGstabl polynomial degree = 2
  Linear System Preconditioning = Diagonal
  Linear System ILUT Tolerance = 1.0e-3
  Linear System Abort Not Converged = False
  Linear System Residual Output = 1
  Linear System Precondition Recompute = 1
End

Equation 1
  Name = "Equation 1"
  Active Solvers(1) = 1
End

Equation 2
  Name = "Equation 2"
  Active Solvers(1) = 1
End

Material 1
  Name = "Gold (generic)"
  Heat expansion Coefficient = 14.2e-6
  Heat Conductivity = 318.0
  Sound speed = 2030.0
  Heat Capacity = 129.0
  Mesh Poisson ratio = 0.44
  Density = 19300.0
  Poisson ratio = 0.44
  Youngs modulus = 78.0e9
End

Body Force 1
  Name = "BodyForce 1"
  Charge Density = 2
End

Initial Condition 1
  Name = "InitialCondition 1"
  Potential = 1
End

Boundary Condition 1
  Target Boundaries(2) = 4 5 
  Name = "BoundaryCondition 1"
  Potential = 1
End

Boundary Condition 2
  Target Boundaries(2) = 1 6 
  Name = "BoundaryCondition 2"
  Potential = 2
End

Boundary Condition 3
  Target Boundaries(1) = 3 
  Name = "BoundaryCondition 3"
  Periodic BC = 15
End

mzenker
Posts: 1741
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: error runing my first model

Post by mzenker » 16 Jul 2018, 15:08

Hi,

according to the sif file, there is no material assigned to the body.
Could it be that you forgot to do "save project" after having assigned the material in the GUI?

HTH,

Matthias

pete2
Posts: 5
Joined: 13 Jul 2018, 17:25
Antispam: Yes

Re: error runing my first model

Post by pete2 » 23 Jul 2018, 15:31

oops, i didn't realise that you had to save project everytime that you change something.

thank you!

Post Reply