Loading saved project and data loss

The graphical user interface of Elmer
Post Reply
monacellif
Posts: 17
Joined: 07 Sep 2011, 09:41
Antispam: Yes

Loading saved project and data loss

Post by monacellif » 09 Apr 2015, 10:16

Hi everybody,
I am experiencing data loss in saving and reloading projects.
When I load a saved project I see geometry and mesh but all other conditions are lost (equations, BC, materials...).
It seems the same problem described here (I have installed the latest version 27/03/2015) viewtopic.php?f=4&t=2690
Did anyone come to a solution?

mzenker
Posts: 1991
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Loading saved project and data loss

Post by mzenker » 13 Apr 2015, 12:52

Hi,

as I said in the other thread: the solution is not to reload an already loaded project. It is not necessary. Only load projects with a freshly opened ElmerGUI. This is a bug in ElmerGUI which is probably not straightforward to fix, and the development resources for ElmerGUI are limited...

Matthias

Coco
Posts: 16
Joined: 01 Apr 2015, 09:01
Antispam: Yes

Re: Loading saved project and data loss

Post by Coco » 18 Apr 2015, 15:18

Hi,

why did you reload project?

I want to say,

you can save sif to another name firstly.

and than

after you reload ,you can re-edit the sif to that you have saved.

Attantion,

you need to modify the file ELMERSOLVER_STARTINFO.

e.g change case.sif to that "another name.sif"

Coco

monacellif
Posts: 17
Joined: 07 Sep 2011, 09:41
Antispam: Yes

Re: Loading saved project and data loss

Post by monacellif » 20 Apr 2015, 17:07

Hi, everybody.
I think I have solved the problem, it is related to having loaded any non standard DEFINITION (File->Definitions->Append -> ***.xml).
If you load any of them, you firstly need to reload it in order to have the project correctly resumed.
Usually I save the whole bunch of definitions with the command Save As in the Elmer Definitions File Editor and then reload them on the new opening of the Elmer GUI.

Post Reply