ElmerGrid generates wrong boundary name

The graphical user interface of Elmer
Post Reply
m42kus
Posts: 5
Joined: 21 May 2017, 20:17
Antispam: Yes

ElmerGrid generates wrong boundary name

Post by m42kus » 22 Aug 2017, 17:02

Hi,

The mesh file (2D unv) attached to this post contains the group names: Face1, Edge1 and Edge3. The Face1 group is generated just fine but the edges have weird names. Here is the mesh.names file ElmerGrid generated for me:

Code: Select all

! ----- names for bodies -----
$ Face1 = 3
! ----- names for boundaries -----
$ bc11 = 11
$ bc12 = 12
$ bc14 = 14
Can anyone tell me why this happends and how to solve it?
Attachments
mesh.unv
(23.04 KiB) Downloaded 32 times

mzenker
Posts: 1747
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: ElmerGrid generates wrong boundary name

Post by mzenker » 23 Aug 2017, 11:08

Hi,

I think your mesh has a problem. When run with -autoclean, ElmerGrid spits errors about unknown element types. When I open your unv file with Salomé (version 7), I see that the face lies in the x-z plane. There have been problems with 2D geometries not lying in the x-y plane. So maybe rotating the face into the x-y plane could improve things.

HTH,

Matthias

mzenker
Posts: 1747
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: ElmerGrid generates wrong boundary name

Post by mzenker » 23 Aug 2017, 11:37

Salomé says that your mesh contains only quadratic elements. I hope however that Elmer(Grid) has no problem with that?

Matthias

raback
Site Admin
Posts: 3277
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: ElmerGrid generates wrong boundary name

Post by raback » 23 Aug 2017, 12:03

Hi

The ordering of nodes in quadratic triangle seemed flawed. This is now fixed. It may have been related to that the BCs where not properly identified. The current "devel" version identifies also Edge1 and Edge3. Fetch it from GitHub or wait the changes to be migrated into the distributions.

-Peter

m42kus
Posts: 5
Joined: 21 May 2017, 20:17
Antispam: Yes

Re: ElmerGrid generates wrong boundary name

Post by m42kus » 23 Aug 2017, 12:40

raback wrote: The ordering of nodes in quadratic triangle seemed flawed. This is now fixed. It may have been related to that the BCs where not properly identified. The current "devel" version identifies also Edge1 and Edge3. Fetch it from GitHub or wait the changes to be migrated into the distributions.
Thanks!

Post Reply