ElmerSolver error, Ubuntu 14.10

Numerical methods and mathematical models of Elmer
Post Reply
stevemi
Posts: 16
Joined: 23 Dec 2014, 23:38
Antispam: Yes

ElmerSolver error, Ubuntu 14.10

Post by stevemi » 06 Jan 2015, 00:08

Tried the magnetodynamics example using ElmerGUI, but got the following error when attempting to run the solver: ERROR:: InitializeElementDescriptions: elements.def not found
elements.def is located at /usr/local/share/elmersolver/lib/elements.def. Tried to add this to my .bashrc file, but no change.
Any suggestions?

kataja
Posts: 73
Joined: 09 May 2014, 16:06
Antispam: Yes

Re: ElmerSolver error, Ubuntu 14.10

Post by kataja » 07 Jan 2015, 11:36

Hi!

Do you get the same error just by running ElmerSolver (or ElmerSolver_mpi) from the command line?

Make sure that the cmake variable ELMER_SOLVER_HOME points to $ELMER_HOME/share/elmersolver. By default it points to $CMAKE_INSTALL_PREFIX/share/elmersolver, but if you change the CMAKE_INSTALL_PREFIX variable within cmake-gui the ELMER_SOLVER_HOME variable will not get updated automatically.

If you don't want to recompile, create an environment variable ELMER_HOME that points to prefix path of your Elmer installation, e.g.

Code: Select all

$ ELMER_HOME=/home/bob/opt/Elmer /home/bob/opt/Elmer/bin/ElmerGUI
Have you tried if apt-get installation works for you? (Here)

Cheers,
Juhani

stevemi
Posts: 16
Joined: 23 Dec 2014, 23:38
Antispam: Yes

Re: ElmerSolver error, Ubuntu 14.10

Post by stevemi » 08 Jan 2015, 00:37

Juhani: Thanks for the suggestions, but nothing works so far, no doubt due to my incomplete understanding of the problem. I'll try to summarize my situation as follows:
* As stated previously, the only problem seems to be a file location incompatibility. I get the same error even when running the solver from the command line.
* I'd rather not try a new installation from, say, apt-get, since it looks OK except for the stated problem. I will re-compile however, if necessary.
* There is no "Elmer" directory or installation, only ElmerGUI, ElmerSolver etc. All are located at /usr/local/bin.
* The location of the elements.def file is as stated previously.
* I've tried every environment variable I can think of, including removing all such variables, but there's no effect.
* The GUI runs regardless of whether or not any environment variables exist, with the same results.
* FYI, the way I compiled this package, it only runs correctly if I use "sudo", but looks OK.
At present I'm at an impasse; not being a programmer or developer, I'm not sure what to do next.
Again, thanks for your help.
Stevemi

kataja
Posts: 73
Joined: 09 May 2014, 16:06
Antispam: Yes

Re: ElmerSolver error, Ubuntu 14.10

Post by kataja » 08 Jan 2015, 14:29

Thats odd. The solver should in your case find the elements.def file. If the binaries ElmerSolver, ElmerGUI, etc.. reside in /usr/local/bin then ELMER_HOME variable should point to /usr/local. Furthermore, make sure you have not defined ELMER_LIB environment variable. The following tricks might work for you.

See if there are any dangling elmer-related environment variables and unset ELMER_LIB at least.

Code: Select all

$ env|grep ELMER
$ unset ELMER_LIB
Then set the ELMER_HOME and launch ElmerSolver or ElmerGUI:

Code: Select all

$ ElmerSolver
or
$ ElmerGUI
If that doesn't work, try setting the ELMER_HOME variable manually

Code: Select all

$ export ELMER_HOME=/usr/local
$ ElmerSolver
or
$ ElmerGUI
-Juhani

stevemi
Posts: 16
Joined: 23 Dec 2014, 23:38
Antispam: Yes

Re: ElmerSolver error, Ubuntu 14.10

Post by stevemi » 08 Jan 2015, 17:35

Juhani: Tried all that you indicated, no change. FYI, have attached an ElmerGUI.log file. Also tried ElmerSolver; as previously, it stops immediately and reports the error.
stevemi
Attachments
ElmerGUI.log
(5.43 KiB) Downloaded 95 times

annier
Posts: 1107
Joined: 27 Aug 2013, 13:51
Antispam: Yes

Re: ElmerSolver error, Ubuntu 14.10

Post by annier » 08 Jan 2015, 17:49

Hi Stevemi,
It seems that your computer doesnot have the tetgen functionality.
Since, you are using Ubuntu 14.10, you need to install many dependencies on your own before you install a software. Many softwares are developed upon traditional tool-kits and updated OS generally are switching towards lighter and newly developed toolkits. So, a newer version of OS may not have many traditional toolkits in its default installation. So, for now, please search for measure that ensures Elmer is built up with tetgen.


Yours
Anil Kunwar

stevemi
Posts: 16
Joined: 23 Dec 2014, 23:38
Antispam: Yes

Re: ElmerSolver error, Ubuntu 14.10

Post by stevemi » 08 Jan 2015, 18:43

Anil: Verified that Elmer was in fact compiled with tetgen; repeated this exercise just to be sure. Apparently, Elmer can't seem to find it.
* tetgen header: /home/sbmiller/elmer/elmerfem/ElmerGUI/Application/plugins/tetgen.h
* tetgen binary: /usr/bin/tetgen
* All other tetgen files: /home/sbmiller/elmer/elmerfem/misc/
stevemi

stevemi
Posts: 16
Joined: 23 Dec 2014, 23:38
Antispam: Yes

Re: ElmerSolver error, Ubuntu 14.10

Post by stevemi » 17 Jan 2015, 19:39

annier: Following a good ElmerGUI install per my latest attempt, the solver works OK, despite the inability to find tetgen, which I really don't need. Examples in the tutorial now run as advertised.
Thanks,
stevemi

annier
Posts: 1107
Joined: 27 Aug 2013, 13:51
Antispam: Yes

Re: ElmerSolver error, Ubuntu 14.10

Post by annier » 17 Jan 2015, 20:59

Hi Stevemi,
I applaud your perseverance in learning new ideas in computer interface. I am inspired with your sheer determination to complete the installation process of Elmer software with enormous patience. I think you can help in mutual learning of innovative ideas evolving with the development of Elmer software. Keep it up.


Yours
Anil Kunwar

Post Reply