ResultOutputSolve behaviour

Numerical methods and mathematical models of Elmer
Post Reply
mark smith
Posts: 208
Joined: 26 Aug 2009, 18:20
Location: Peterborough, England

ResultOutputSolve behaviour

Post by mark smith » 15 Sep 2009, 14:44

Hi Elmer team
In my sif file I have in the header section
Header
Mesh DB "mesh"
Include Path ""
Results Directory ""
End
I then have 2 solvers for resultoutput i.e.

Solver 2
Exec solver = "After timestep"
Equation = "ResultOutput"
Procedure = "ResultOutputSolve" "ResultOutputSolver"
Output File Name = String "venturi_swirl_3D_2"
Output Format = string "gid"
Gid Format = Logical true
Scalar Fields = Integer 3
Scalar Field 1 = String "Pressure"
Vector Fields = Integer 1
Vector Field 1 = String "Velocity"
End

Solver 3
Exec solver = "After timestep"
Equation = Result Output
Procedure = "ResultOutputSolve" "ResultOutputSolver"
Output File Name = "venturi_swirl_3D_2"
Output Format = Vtk
End

Running the solver from the command line I obtain both the GiD & vtk format results file but strangely they are not put in the same place? The Gid output is placed in the directory where the sif file is as expected but the vtk output is put in the "mesh" directory?

If I try to launch the solver through the ElmerGui interface with the same header section & my mesh files in the "mesh" directory the Elmersolver log tells me it cannot read the mesh header? but if I put the mesh files in the the same place as the sif file then all is OK?
In the ElmerGui model setup page there are 2 fields for the meshDB can you explain what these need to be set to please?

OS windowsXP , Elmersolver 5.5.0 Rev4219

Regards
mark

Post Reply