Segmentation fault - invalid memory reference.

Numerical methods and mathematical models of Elmer
Post Reply
yuanxun
Posts: 17
Joined: 20 Feb 2019, 14:04
Antispam: Yes

Segmentation fault - invalid memory reference.

Post by yuanxun » 15 Mar 2019, 09:29

Hi

I was running a simulation about heat transfer between air and wall.
But error "Program received signal SIGSEGV: Segmentation fault - invalid memory reference."appeared when running.
I have no idea about what's wrong with it. Here's the solver log and sif file.

Code: Select all

ELMER SOLVER (v 8.3) STARTED AT: 2019/03/15 14:22:53
ParCommInit:  Initialize #PEs:            1
MAIN: 
MAIN: =============================================================
MAIN: ElmerSolver finite element software, Welcome!
MAIN: This program is free software licensed under (L)GPL
MAIN: Copyright 1st April 1995 - , CSC - IT Center for Science Ltd.
MAIN: Webpage http://www.csc.fi/elmer, Email elmeradm@csc.fi
MAIN: Version: 8.3 (Rev: 432ee0dd, Compiled: 2018-12-18)
MAIN:  Running one task without MPI parallelization.
MAIN:  Running with just one thread per task.
MAIN:  Lua interpreted linked in.
MAIN: =============================================================
MAIN: 
MAIN: 
MAIN: -------------------------------------
MAIN: Reading Model: case.sif
LoadInputFile: Scanning input file: case.sif

LoadInputFile: Loading input file: case.sif
Loading user function library: [HeatSolve]...[HeatSolver_Init0]
LoadMesh: Base mesh name: ./.
LoadMesh: Elapsed REAL time:     0.0460 (s)
MAIN: -------------------------------------
AddVtuOutputSolverHack: Adding ResultOutputSolver to write VTU output in file: case
Loading user function library: [HeatSolve]...[HeatSolver_Init]
Loading user function library: [HeatSolve]...[HeatSolver_bulk]
Loading user function library: [HeatSolve]...[HeatSolver]
OptimizeBandwidth: ---------------------------------------------------------
OptimizeBandwidth: Computing matrix structure for: heat equation...done.
OptimizeBandwidth: Half bandwidth without optimization: 716
OptimizeBandwidth: 
OptimizeBandwidth: Bandwidth Optimization ...done.
OptimizeBandwidth: Half bandwidth after optimization: 95
OptimizeBandwidth: ---------------------------------------------------------
Loading user function library: [ResultOutputSolve]...[ResultOutputSolver_Init]

Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0  ffffffffffffffff
Loading user function library: [ResultOutputSolve]...[ResultOutputSolver_bulk]
Loading user function library: [ResultOutputSolve]...[ResultOutputSolver]
MAIN: 
MAIN: -------------------------------------
MAIN:  Steady state iteration:            1
MAIN: -------------------------------------
MAIN: 
SingleSolver: Attempting to call solver
SingleSolver: Solver Equation string is: heat equation
HeatSolver: Solving the energy equation for temperature
HeatSolve: 
HeatSolve: 
HeatSolve: -------------------------------------
HeatSolve:  TEMPERATURE ITERATION           1
HeatSolve: -------------------------------------
HeatSolve: 
HeatSolve: Starting Assembly...
HeatSolve: Assembly:
Thanks a lot.
Attachments
case.sif
(3.19 KiB) Downloaded 14 times

kevinarden
Posts: 140
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Segmentation fault - invalid memory reference.

Post by kevinarden » 15 Mar 2019, 11:43

Possibly a mesh issue, can you post the mesh? You have steady state selected but also have time steps defined. Are you doing steady state or transient?

yuanxun
Posts: 17
Joined: 20 Feb 2019, 14:04
Antispam: Yes

Re: Segmentation fault - invalid memory reference.

Post by yuanxun » 15 Mar 2019, 13:25

Hi

I changed it to steady state.
And here's the mesh file exported by salome.
Thank you.

Yuanxun
Attachments
tt.unv
(700.64 KiB) Downloaded 12 times

kevinarden
Posts: 140
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Segmentation fault - invalid memory reference.

Post by kevinarden » 16 Mar 2019, 02:10

This is the solution using your mesh and sif. However I could not use your unv as is, I had to import it into salome and export it again.
solution.png
(66.29 KiB) Not downloaded yet

yuanxun
Posts: 17
Joined: 20 Feb 2019, 14:04
Antispam: Yes

Re: Segmentation fault - invalid memory reference.

Post by yuanxun » 16 Mar 2019, 06:35

Thanks a lot.

Maybe it's the elmerGUI‘s error,I'd like to install it again.

kevinarden
Posts: 140
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Segmentation fault - invalid memory reference.

Post by kevinarden » 16 Mar 2019, 12:37

There are errors in ElmerGUI for mesh translation, you can use ElmerGrid from the command line to convert. Type ElmerGrid to get a list of options.

Post Reply