WhitneyAVSolver does not converge despite all effort

Numerical methods and mathematical models of Elmer
Post Reply
gedro
Posts: 1
Joined: 13 Jun 2018, 09:44
Antispam: Yes

WhitneyAVSolver does not converge despite all effort

Post by gedro » 13 Jun 2018, 15:34

Hello,

I am trying to calculate the magnetic flux density in an air gap with a two coil setup. But despite everything I tried (mostly looked up in this forum), I can't get a converging solution:
I tried to simplify the geometry to get the thing running.
I tried several preconditioners - "diagonal", ILU(1), ILU(2), "None" (from Models Manual) as well as iterative solvers BiCGStab and BiCGStab(L).
I switched from CoilSolver based current density to an analytical function (MATC).
I limited the Body Force/Current Density to a single coil.

The mesh was generated with NetGen 5.3 and the solver input file with ElmerGUI. I cannot find any mistake in the sif file, but still it does not converge. Any ideas what goes wrong with it?
test_4.zip
(248.62 KiB) Downloaded 21 times
--
Best Regards
Georg

mzenker
Posts: 1806
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: WhitneyAVSolver does not converge despite all effort

Post by mzenker » 13 Jun 2018, 16:48

Hi,

I do not use the MgDyn solver myself. However, I quickly tried to run your case. I see divergence as well. Your geometry seems quite large to me, it has a diameter of 4000 length units. Elmer assumes m by default, so this would be 4 km. If you want to scale the length units to mm, you can say

Coordinate Scaling = 0.001

in the simulation section (free text field in Model>Setup). That does not cure the divergence however, so there must be something else. Maybe you can try to start with a tutorial or a case which is veery simple in order to get something to run. Sorry that I cannot help further as I do not know this solver well enough...

Matthias

Post Reply