Problem with accessing Elmer ppa

Discussion about building and installing Elmer
Post Reply
Gary R
Posts: 108
Joined: 12 Apr 2012, 07:23
Antispam: Yes
Location: Long Beach CA, USA

Problem with accessing Elmer ppa

Post by Gary R »

Debian has started tightening up on security of late. Because of this I can no longer download from Elmer ppa. I get the following"

Code: Select all

root@ctech:/etc/apt# add-apt-repository ppa:elmer-csc-ubuntu/elmer-csc-ppa
 Archive for the monolithic Elmer FEM software ubuntu packages.
 More info: https://launchpad.net/~elmer-csc-ubuntu/+archive/ubuntu/elmer-csc-ppa
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keybox '/tmp/tmpesl6mv32/pubring.gpg' created
gpg: /tmp/tmpesl6mv32/trustdb.gpg: trustdb created
gpg: key 89358ABF9FB7E178: public key "Launchpad PPA for Elmer CSC ubuntu packaging" imported
gpg: Total number processed: 1
gpg:               imported: 1
gpg: no valid OpenPGP data found.
root@ctech:/etc/apt# apt update
Hit:1 http://security.debian.org/debian-security stable/updates InRelease
Hit:2 https://repo.skype.com/deb stable InRelease                                    
Hit:3 http://mirror.keystealth.org/debian stable InRelease                           
Hit:4 http://mirror.keystealth.org/debian stable-updates InRelease       
Ign:5 http://ppa.launchpad.net/elmer-csc-ubuntu/elmer-csc-ppa/ubuntu groovy InRelease
Err:6 http://ppa.launchpad.net/elmer-csc-ubuntu/elmer-csc-ppa/ubuntu groovy Release
  404  Not Found [IP: 91.189.95.83 80]
Reading package lists... Done
E: The repository 'http://ppa.launchpad.net/elmer-csc-ubuntu/elmer-csc-ppa/ubuntu groovy Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
I don't quite know what is involved with adding a Release file. I'm not even sure that that is the real problem. See the error at line 6. My "sources.list.d" directory includes the following:

Code: Select all

-rw-r--r-- 1 root root 164 Oct  3 12:41 elmer-csc-ubuntu-ubuntu-elmer-csc-ppa-groovy.list
I followed the ppa installation instructions to the letter.

Gary R.
raback
Site Admin
Posts: 4066
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: Problem with accessing Elmer ppa

Post by raback »

Hi

I guess there are no instructions for release "Groovy" of Ubuntu. Just tried to copy the instructions from "Disco" to "Groovy" and "Focal". The 1st one has some problems whereas the 2nd one seems to compile...

https://code.launchpad.net/~elmer-csc-u ... ily-groovy
https://code.launchpad.net/~elmer-csc-u ... aily-focal

The problem seems to be that Groovy is picky on the argument mismatch of old Fortran routines in Arpack but does not care of our fix for it (using -std=legacy). Focal and Disco are happy with the exact same build rule.

-Peter
kevinarden
Posts: 1027
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Problem with accessing Elmer ppa

Post by kevinarden »

this system is using apt-secure and since there is no release file in the repository it is disabled by default, you can by pass the disable on apt-get by using the option

Pass the --allow-unauthenticated option to apt-get as in:

sudo apt-get --allow-unauthenticated upgrade
raback
Site Admin
Posts: 4066
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: Problem with accessing Elmer ppa

Post by raback »

Hi

"elmerfem-csc" and "elmerfem-csc-eg" seem to compile on "Groovy". Do you still get this problem with authentication?

-Peter
Gary R
Posts: 108
Joined: 12 Apr 2012, 07:23
Antispam: Yes
Location: Long Beach CA, USA

Re: Problem with accessing Elmer ppa

Post by Gary R »

Sorry about the long delay on answering this. Got tied up with a lot of other things. Short answer the problem persists. But, i am locked out of all of the ppa's that i've tried to use since Debian started messing around with the security. I gave up and compiled from source code. Works fine. i noticed that verson 9 is out. I may install that.

Thanks for you previous replies and, again, sorry about the delayed reply.

Gary R
Post Reply