How to compile Elmer fem on macOS with OpenMPI, Hypre and Mumps

Discussion about building and installing Elmer
Post Reply
tutu10
Posts: 1
Joined: 10 Apr 2019, 11:19
Antispam: Yes

How to compile Elmer fem on macOS with OpenMPI, Hypre and Mumps

Post by tutu10 » 10 Apr 2019, 11:25

I'm trying to modify the instructions in this page to compile Elmer on macOS (High Sierra 10.13.5).

I installed gcc, cmake, open-mpi and hypre from HomeBrew core and followed this instruction to install mumps from dpo/openblas. I downloaded the source code with:

svn checkout http://svn.code.sf.net/p/elmerfem/code/trunk elmerfem

I made this bash script following the instructions in that page and make it executable chmod u+x compile and ran it ./compile. However I get lots of warnings/errors which I don't know how to solve. I tried to direct the stream into a logfile which you can see in the same GitHub Gist, but apparently it did not include everything. The last couple of lines I see in the stream are:

Types.f90:354: Error: Can't open included file 'dmumps_struc.h'

make3: *** [Types.o] Error 1

make2: *** [all-recursive] Error 1

make1: *** [all-recursive] Error 1

make: *** [all] Error 2

I assumed it should be because the compiler somewhere is including the dmumps_struc.hheader. so I tried editing the script adding the mumps static libraries in

/usr/local/opt/mumps/libexec/lib

and it didn't even compile the first modules either. I would appreciate if you could help me know where is my mistake and how I can solve it.

kevinarden
Posts: 244
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: How to compile Elmer fem on macOS with OpenMPI, Hypre and Mumps

Post by kevinarden » 10 Apr 2019, 11:53

is the dmumps_struc.h file on the computer? Sometimes when compiling you have to have the developer libraries of the dependencies not just the dependencies. i.e libmumps-dev not jjust libmumps

kataja
Posts: 74
Joined: 09 May 2014, 16:06
Antispam: Yes

Re: How to compile Elmer fem on macOS with OpenMPI, Hypre and Mumps

Post by kataja » 17 Apr 2019, 14:26

Hi,

the up to date source repository of Elmer is at github: https://github.com/ElmerCSC/elmerfem
.
The source code at svn.code.sf.net is, sadly, outdated. I wonder if that could be removed..

Cheers,
Juhani

Post Reply