One file missing - versionComp

Discussion about building and installing Elmer
Post Reply
joni
Posts: 21
Joined: 10 Mar 2018, 15:05
Antispam: Yes

One file missing - versionComp

Post by joni » 12 Feb 2019, 11:03

hi,

I suggest to add versionComp or prerequsities
file to the top.

It should include library versions supported.

For example I rememeber that MUMPS max version was
several years ago 4.0.0 even 5.1.2 is out, there is
diffrence at calling convetions,...

Now I can not find any references is elmerfem code
hacked to support new MUMPS and also good
question is dose it support older one.

If it question a one library it's not problem
but when there is dozen then testing all
them takes week's, also there is difrences
like parraller/sequential compatibelity,,..
also some basic libraryes interact to many
libraryes,...

joni

Post Reply