ElmerGUI command not found

Discussion about building and installing Elmer
ulrich
Posts: 8
Joined: 15 Jun 2018, 19:47
Antispam: Yes

ElmerGUI command not found

Post by ulrich » 28 Jul 2018, 03:27

Hello comunity,
i tried to install it on Ubuntu 18.04 unsuccessfully and on Ubuntu Mate 18.04 too.
See
elmerfem-csc (8.3-0ppa0-201807190101~11e34a2~ubuntu18.04.1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
cosinus@Rechner001:~$ elmerGui
elmerGui: Befehl nicht gefunden.

That means: ElmerGUI command not found.
I'm disappointed.

Best regards, ulrich

KaiMartin
Posts: 34
Joined: 02 Jun 2013, 00:07
Antispam: Yes
Location: Hannover, Germany
Contact:

Re: ElmerGUI command not found

Post by KaiMartin » 28 Jul 2018, 13:49

ulrich wrote:
28 Jul 2018, 03:27
cosinus@Rechner001:~$ elmerGui
elmerGui: Befehl nicht gefunden.

That means: ElmerGUI command not found.
It means 'elmerGUI' not found.
You may try 'ElmerGUI'. I.e. with a capital E. Linux is case sensitive.

If the command is still not found, you can check with the search tool 'locate'. If it isn't already present you may install the package 'mlocate' to make it available.

Hope that helps.
---<)kaimartin(>---

kataja
Posts: 73
Joined: 09 May 2014, 16:06
Antispam: Yes

Re: ElmerGUI command not found

Post by kataja » 30 Jul 2018, 13:58

Did you install package including ElmerGUI? See https://github.com/ElmerCSC/elmerfem/wiki/Packages for details.

ulrich
Posts: 8
Joined: 15 Jun 2018, 19:47
Antispam: Yes

Re: ElmerGUI command not found

Post by ulrich » 31 Jul 2018, 11:38

Hello,
perhaps like that :
$ sudo add-apt-repository ppa:elmer-csc-ubuntu/elmer-csc-eg-ppa
$ sudo apt-get update
$ sudo apt-get install elmerfem-csc-eg

and not
$ sudo add-apt-repository ppa:elmer-csc-ubuntu/elmer-csc-ppa
$ sudo apt-get update
$ sudo apt-get install elmerfem-csc
?
I'll try again.

Thanks for avising,
Ulrich

ulrich
Posts: 8
Joined: 15 Jun 2018, 19:47
Antispam: Yes

Re: ElmerGUI command not found

Post by ulrich » 02 Aug 2018, 00:18

Solved !!!!!!!!!!!!
That new Ubuntu 18.04 LTS lacks libqt5xml5.
I had to install it with "sudo apt-get install libqt5xml5".
Your ulrich

ulrich
Posts: 8
Joined: 15 Jun 2018, 19:47
Antispam: Yes

Re: ElmerGUI command not found

Post by ulrich » 10 Aug 2018, 14:44

Dear community,

at 01 Aug 2018 i was happy, that i was able to start ElmerGUI.
But now i found that the PARAVIEW is missing.
(ELMERPOST is also missing, it is a pitty, but i knew that it is not more continued by the developers.)

Any idea ?
Best regards,
Ulrich

raback
Site Admin
Posts: 3330
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: ElmerGUI command not found

Post by raback » 10 Aug 2018, 17:13

Hi

Have you tried installing from:
https://www.paraview.org/download/

-Peter

ulrich
Posts: 8
Joined: 15 Jun 2018, 19:47
Antispam: Yes

Re: ElmerGUI command not found

Post by ulrich » 10 Aug 2018, 17:25

Hallo Peter,
thank u vm 4 ur fast reply.

No, i did not. I thought it would be included.
I believe on my former Ubuntu Mate 16.04 LTS my ELMER contained PARAVIEW.
Nevertheless i see no other way than to install it separately.

Have nice Weekend,
best regards,
Ulrich

raback
Site Admin
Posts: 3330
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: ElmerGUI command not found

Post by raback » 10 Aug 2018, 22:51

Hi

Could it be that you were running the virtual machine including Elmer binaries and all related software.

http://www.nic.funet.fi/pub/sci/physics ... lMachines/

If you install your own native Mint you need to add these software separately.

-Peter

activ25
Posts: 18
Joined: 31 Oct 2018, 21:04
Antispam: Yes

Re: ElmerGUI command not found

Post by activ25 » 02 Nov 2018, 09:15

Hi,

I have the same problem, I'm on Linux Mint based on Ubuntu 16, the install seems correct (no error) but ElmerGUI not found, and it is true, the file doens't exist on the disk, I launched a command 'find'. I try all advice in this thread but nothing works. Someone knows ?

Edit: I tried to compile but Fortran need to be install, I installed gfortan (I don't know if it is that he wants) but another error ZOLTAN not found.

Regards
Ludovic

Post Reply