elmer-ice homebrew install

Discussion about building and installing Elmer
Post Reply
hoffmaao
Posts: 3
Joined: 20 Jun 2018, 21:44
Antispam: Yes

elmer-ice homebrew install

Post by hoffmaao »

I have tried to install elmer/ice on my macOS high sierra 10.13.3 using the homebrew install, but I get the following error after entering the appropriate brew commands:

brew tap elmercsc/homebrew-elmerfem

brew install elmer --HEAD --with-elmerice

"Installing elmer from elmercsc/elmerfem
Error: Operation already in progress for scalapack.formula
Another active Homebrew process is already using scalapack.formula.
Please wait for it to finish or terminate it to continue."

I have tried to remove the locks in hombrew and ran "brew cleanup" and "brew update" without any luck. Scalapack used to be part of the homebrew core, but is shadowed by dpo/openblas. I have the dpo/openblas/scalapack 2.0.2 installed and completely updated on my machine, which I have reinstalled, but the error persists. Out of curiosity, I used a different machine with the same operating system and got the same error. Any suggestions are much appreciated.

Cheers,
Andrew
hoffmaao
Posts: 3
Joined: 20 Jun 2018, 21:44
Antispam: Yes

Re: elmer-ice homebrew install

Post by hoffmaao »

Update:

Installing elmer/ice on macOS 10.13.5 required some minor modifications of the elmer.rb file. First, I had to comment out depends_on "scalapack" to get rid of the error mentioned previously. Next, I added the following line to cmake script

cmake_args = %W[-DCMAKE_INSTALL_PREFIX=#{prefix}]
cmake_args << "-DCMAKE_Fortran_COMPILER_SUPPORTS_CONTIGUOUS=FALSE" #new argument for gfortran-8

These are the packages I have installed from homebrew:

cmake 3.11.4
elmer 8.2
gcc 8.1.0
gcc@7 7.3.0
gdbm 1.15
gettext 0.19.8.1
gmp 6.1.2_2
hypre 2.11.2_3
isl 0.19
libevent 2.1.8
libidn2 2.0.5
libmpc 1.1.0
libunistring 0.9.10
mpfr 4.0.1
mumps 5.1.2
open-mpi 3.1.0
openblas 0.3.0
openssl 1.0.2o_2
python 3.6.5_1
qt 5.11.1
readline 7.0.3_1
scalapack 2.0.2
sqlite 3.24.0
veclibfort 0.4.2_6
wget 1.19.5
xz 5.2.4
foadsf
Posts: 17
Joined: 20 Sep 2016, 23:56
Antispam: Yes

Re: elmer-ice homebrew install

Post by foadsf »

I followed the edits as I explained here:
https://github.com/ElmerCSC/homebrew-elmerfem/issues/11
So Elmer installs but when I use the --with-elmergui I get this error:

CMake Error at /usr/local/Cellar/cmake/3.11.4/share/cmake/Modules/FindQt4.cmake:1321 (message):
Found unsuitable Qt version "5.11.1" from /usr/local/opt/qt/bin/qmake, this
code requires Qt 4.x
Call Stack (most recent call first):
ElmerGUI/CMakeLists.txt:16 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
See also "/tmp/elmer-20180708-37613-zn9ojg/elmerfem-release-8.2/build/CMakeFiles/CMakeOutput.log".

If reporting this issue please do so at (not Homebrew/brew or Homebrew/core):
https://github.com/elmercsc/homebrew-elmerfem/issues

These open issues may also help:
Elmer build error on 10.11.6 https://github.com/ElmerCSC/homebrew-elmerfem/issues/6
Umfpack problem while compiling Elmer with homebrew https://github.com/ElmerCSC/homebrew-elmerfem/issues/2
Elmer failed to build on OS 10.12.6 https://github.com/ElmerCSC/homebrew-elmerfem/issues/8
Unable to install elmer on Mac by using brew https://github.com/ElmerCSC/homebrew-elmerfem/issues/1
Elmer failed to build on OS 10.12.1 https://github.com/ElmerCSC/homebrew-elmerfem/issues/5
Post Reply