internal compiler error (SOLVED)

Discussion about building and installing Elmer
Post Reply
Gary R
Posts: 60
Joined: 12 Apr 2012, 07:23
Antispam: Yes
Location: Long Beach CA

internal compiler error (SOLVED)

Post by Gary R » 22 Feb 2018, 00:19

For reasons left unsaid, I needed to recompile Elmer with Trilinos. I use Cmake-GUI. My setup is a Debian host and Ubuntu guest on qemu/kvm virtual machine. Elmer was compiled with Contrib, ElmerGUI, Mumps, OpenMP and Trilinos. The Configure and Generate went well. When I ran make, I got the following error:

Code: Select all

[ 64%] Building Fortran object fem/src/CMakeFiles/elmersolver.dir/ListMatrixArray.F90.o
[ 67%] Built target ElmerGUI
/home/gary/Elmer/elmerfem/fem/src/H1Basis.F90:81:0:

   END SUBROUTINE H1Basis_GetEdgeDirection
 
internal compiler error: in fold_convert_loc, at fold-const.c:2269
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-7/README.Bugs> for instructions.
fem/src/CMakeFiles/elmersolver.dir/build.make:2006: recipe for target 'fem/src/CMakeFiles/elmersolver.dir/H1Basis.F90.o' failed
I have no idea what to do with this. I can't believe that a bug in the gfortran compiler just popped up. This compiler is used for all kinds of programs. Is there a fix for this without filing a bug report?

Please help
Gary R
Last edited by Gary R on 24 Mar 2018, 01:17, edited 1 time in total.

raback
Site Admin
Posts: 3330
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: internal compiler error

Post by raback » 22 Feb 2018, 10:25

Hi Gary,

Sorry, difficult to suggest anything. Usually there is a way to circumvent compiler bugs if you can locate it. It is not unheard of that there would be a compiler bug. I think that Elmer project has over the years given rise to around ten compiler bug reports on various compilers.

The latest one is described here:
https://github.com/ElmerCSC/elmerfem/issues/127

-Peter

Gary R
Posts: 60
Joined: 12 Apr 2012, 07:23
Antispam: Yes
Location: Long Beach CA

Re: internal compiler error (SOLVED)

Post by Gary R » 27 Feb 2018, 03:35

Thanks for the reply, It turns out that running make more than once cleared the problem. I think that the ram of my virtual environment overloaded.


Gary R

Post Reply