ubuntu packages on lounchpad broken

Discussion about building and installing Elmer
bernd
Posts: 21
Joined: 29 Nov 2016, 15:03
Antispam: Yes

Re: ubuntu packages on lounchpad broken

Post by bernd »

mzenker wrote:stupid question: does this affect any part of the Elmer suite except ElmerGUI?
How about distributing ElmerGUI in a separate package, so that ElmerSolver and ElmerGrid can at least be installed on (almost) all systems?
Wow, that would be cool, I only need ElmerGrid and ElmerSolver !
mzenker
Posts: 1998
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: ubuntu packages on lounchpad broken

Post by mzenker »

In that case, you could also try to compile only those, that would make compilation a lot easier.
bernd
Posts: 21
Joined: 29 Nov 2016, 15:03
Antispam: Yes

Re: ubuntu packages on lounchpad broken

Post by bernd »

Is there some doku how to do that only?
mzenker
Posts: 1998
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: ubuntu packages on lounchpad broken

Post by mzenker »

Hi,

I have done a compilation some time ago on Linux Mint 17, but not entirely successful. Have a look at this thread viewtopic.php?f=2&t=3742&start=0&sid=de ... bf40905458, you will find much info there.

HTH,

Matthias

Remark: The need for up-to-date compilation instructions at least for some of the most popular Linux distros (e.g. Ubuntu LTS) is still there. It would be very nice if they could be maintained by the Elmer team at a place where the community can find them. Maybe one could just regularly publish the compilation scripts and library dependencies used for building the launchpad packages...?
bernd
Posts: 21
Joined: 29 Nov 2016, 15:03
Antispam: Yes

Re: ubuntu packages on lounchpad broken

Post by bernd »

gave compiling a try. see viewtopic.php?f=2&t=4997&start=0
etorg
Posts: 2
Joined: 26 Oct 2020, 13:06
Antispam: Yes

Re: ubuntu packages on lounchpad broken

Post by etorg »

Hello, I am new to this forum.

Using Ubuntu-Mate 20.04 upgrade I was tying to use download *.deb files.
All other prerequisite libraries could successfully be installed.

Unfortunately I allways get "missing libgfortran" with all versions, although fortan is installed and working.

Compiling runs with warnings and fails due to other reasons, not Fortran. Unexperienced with compiling large systems I would prefer installing from a *.deb file. I do not need the latest version. Where can I find it?
raback
Site Admin
Posts: 3889
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: ubuntu packages on lounchpad broken

Post by raback »

Hi

Several deb packages should be available from launchpad:
https://launchpad.net/~elmer-csc-ubuntu ... er-csc-ppa

Those with ending "-eg" include the GUI, the vanilla version not. The 20.04 with the GUI happens to be broken (looking at it), but the non-gui version seems to compile there ok.

Attached is also the script used in our VM to compile Elmer for Ubuntu 20.04

-Peter
Attachments
buildelmer.txt
Scipt working on Ubuntu 20.04
(978 Bytes) Downloaded 46 times
Post Reply