Compiling ElmerGui on Mac - has anyone done it?

Discussion about building and installing Elmer

Compiling ElmerGui on Mac - has anyone done it?

Postby Spranky63 » 07 Jan 2017, 18:12

Hi

I was wondering how many people have successfully installed elmerGUI on a Mac? Not the old binary at trueflaw.com either.

I have OS 10.11.6 and have been trying, as have a few others, to install the elmerGUI of 8.2. I have been using homebrew and details of the installation battle can be found here:

https://github.com/ElmerCSC/homebrew-elmerfem/issues/6

I had to modify the Findqt.cmake files as there was some conflict between qt4 (needed by elmerGui) and qt5 which the Homebrew installed qwt depends on. In one of the posts from me, Spranky63 in the link, is my 02.make log file which shows make fail at about 75%. I am using Xcode 8.2.1, Homebrew 1.1.6, gcc 6.3, OS 10.11.6.

The compilation gets to : [ 75%] Linking Fortran shared library libelmersolver.dylib

Elmersolver, Elmergrid all work fine.

So who actually runs elmer on a Mac and uses elmerGUI? And if so could you share how you got it to install and under what conditions/versions.

Thanks to anyone that can provide some insight.
Spranky63
 
Posts: 1
Joined: 07 Jan 2017, 09:02

Re: Compiling ElmerGui on Mac - has anyone done it?

Postby sbishop58 » 26 Jun 2017, 03:09

Spranky63,
I am a real novice but would like to try installation on OS X 10.10.5 using home-brew. were you able to resolve the installation issue?
Do you think I will encounter the same problem? I've got Homebrew 1.2.3, gcc 7.0.2 and OS X 10.10.5. My recent brewup, today, issued the reformulation qt5 -> qt.

So I'll risk it and give it a try this evening.


Steve
sbishop58
 
Posts: 4
Joined: 15 Mar 2016, 04:09


Return to Installation & compilation

Who is online

Users browsing this forum: Google [Bot] and 1 guest

cron