QT5 Error with Homebrew Install for Elmergui on OSX 10.11

Discussion about building and installing Elmer

QT5 Error with Homebrew Install for Elmergui on OSX 10.11

Postby oleole » 16 Dec 2016, 12:14

Hallo,
I am trying to install Elmer via brew on my Mac running OSX 10.11.6

I use this formula
https://github.com/ElmerCSC/homebrew-elmerfem

and ran
brew install elmer.rb --with-elmergui --HEAD

brew downloads QT5 as a dependency but later in the cmake build process I get this error.

CMake Error at /usr/local/Cellar/cmake/3.7.1/share/cmake/Modules/FindQt4.cmake:1318 (message):
Found unsuitable Qt version "5.7.0" from /usr/local/opt/qt5/bin/qmake, this
code requires Qt 4.x

I tried to search online but could not find a solution.

Did anyone encounter the same issue and know how to fix?

Thanks for any help :)


I also created an issue on github here:
https://github.com/ElmerCSC/homebrew-elmerfem/issues/6
oleole
 
Posts: 2
Joined: 02 Dec 2016, 07:12

Return to Installation & compilation

Who is online

Users browsing this forum: No registered users and 3 guests

cron