compile and run on Debian Jessie

Discussion about building and installing Elmer

compile and run on Debian Jessie

Postby bernd » 05 Dec 2016, 14:53

Hi,

I'm new to Elmerfem and would like to give it a try. I cloned the devel github. Cmake and make did quite well, from my point of view. I'm at

Code: Select all
$ git log -1
commit 4fb13d7cb246737a6eeec7d0d6561898a88f5aa3
Author: Peter Raback <peter.raback@csc.fi>
Date:   Fri Dec 2 14:16:15 2016 +0200

    small fix to test case
$
$ git log -10 --oneline
4fb13d7 small fix to test case
9ff82c1 Merge branch 'devel' into SolverLibTests
f9e18f1 Remove some tests that do not pass, for now
57156d7 Merge pull request #77 from ElmerCSC/RemoveObsolite
2a8d137 Drop one case in parallel tests as somewheat redundant
ace5bb2 ElmerGrid saves node and element indexes as int32 when writing ascii vtu format
2ccd3d1 fix to test case
dc0ac1e fix to test case
78544fe Added some Hypre tests
6c1643c added some test which will test external libraries
$


But when I start the solver binary ElmerSolver_mpi from build directory with an example I get the following error. It seams I'm not the first one with this but I could not solve it myself.

Code: Select all
$ cd /home/hugo/Documents/projekte--BIM--opendev/dev--elmerfem/example
hugo@ahorn:~/Documents/projekte--BIM--opendev/dev--elmerfem/example$ /home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/ElmerSolver_mpi  BDM.sif
ELMER SOLVER (v 8.2) STARTED AT: 2016/12/05 12:52:13
[ahorn:10905] [[INVALID],INVALID] ORTE_ERROR_LOG: A system-required executable either could not be found or was not executable by this user in file ess_singleton_module.c at line 231
[ahorn:10905] [[INVALID],INVALID] ORTE_ERROR_LOG: A system-required executable either could not be found or was not executable by this user in file ess_singleton_module.c at line 140
[ahorn:10905] [[INVALID],INVALID] ORTE_ERROR_LOG: A system-required executable either could not be found or was not executable by this user in file runtime/orte_init.c at line 128
--------------------------------------------------------------------------
It looks like orte_init failed for some reason; your parallel process is
likely to abort.  There are many reasons that a parallel process can
fail during orte_init; some of which are due to configuration or
environment problems.  This failure appears to be an internal failure;
here's some additional information (which may only be relevant to an
Open MPI developer):

  orte_ess_set_name failed
  --> Returned value A system-required executable either could not be found or was not executable by this user (-127) instead of ORTE_SUCCESS
--------------------------------------------------------------------------
--------------------------------------------------------------------------
It looks like MPI_INIT failed for some reason; your parallel process is
likely to abort.  There are many reasons that a parallel process can
fail during MPI_INIT; some of which are due to configuration or environment
problems.  This failure appears to be an internal failure; here's some
additional information (which may only be relevant to an Open MPI
developer):

  ompi_mpi_init: orte_init failed
  --> Returned "A system-required executable either could not be found or was not executable by this user" (-127) instead of "Success" (0)
--------------------------------------------------------------------------
[ahorn:10905] *** An error occurred in MPI_Init
[ahorn:10905] *** on a NULL communicator
[ahorn:10905] *** Unknown error
[ahorn:10905] *** MPI_ERRORS_ARE_FATAL: your MPI job will now abort
--------------------------------------------------------------------------
An MPI process is aborting at a time when it cannot guarantee that all
of its peer processes in the job will be killed properly.  You should
double check that everything has shut down cleanly.

  Reason:     Before MPI_INIT completed
  Local host: ahorn
  PID:        10905
--------------------------------------------------------------------------
hugo@ahorn:~/Documents/projekte--BIM--opendev/dev--elmerfem/example$


cheers Bernd

PS: A few of you guys I have met already at the FreeCAD FEM forum. I use the same name over there.
bernd
 
Posts: 9
Joined: 29 Nov 2016, 15:03

Re: compile and run on Debian Jessie

Postby vencels » 05 Dec 2016, 15:42

Hi,
I am usually using these commands for compiling:
Code: Select all
cmake -DWITH_MPI=TRUE -DCMAKE_BUILD_TYPE=Release ../elmerfem
make -j
sudo make install


...and running:
Code: Select all
mpirun -n 1 ElmerSolver_mpi


Can you try?
vencels
 
Posts: 17
Joined: 20 Sep 2016, 17:05
Location: Latvia

Re: compile and run on Debian Jessie

Postby bernd » 05 Dec 2016, 19:57

Thanks for your hints. I compiled with:

Code: Select all
cmake ../elmerfem -DWITH_MPI=True -DCMAKE_BUILD_TYPE=Release


run two example I found with:
Code: Select all
mpirun -n 1   /home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/ElmerSolver_mpi  BDM.sif
or
mpirun -n 1   /home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/ElmerSolver_mpi   calculix_canti/case.sif


On both example some file is missing:
Code: Select all
hugo@ahorn:~/Documents/dev/elmerfem/elmerfem-dev/build$ mpirun -n 1   /home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/ElmerSolver_mpi   calculix_canti/case.sif
ELMER SOLVER (v 8.2) STARTED AT: 2016/12/05 17:54:15
ParCommInit:  Initialize #PEs:            1
MAIN:
MAIN: =============================================================
MAIN: ElmerSolver finite element software, Welcome!
MAIN: This program is free software licensed under (L)GPL
MAIN: Copyright 1st April 1995 - , CSC - IT Center for Science Ltd.
MAIN: Webpage http://www.csc.fi/elmer, Email elmeradm@csc.fi
MAIN: Version: 8.2 (Rev: 4fb13d7, Compiled: 2016-12-05)
MAIN: =============================================================
ERROR:: InitializeElementDescriptions: elements.def not found
--------------------------------------------------------------------------
mpirun has exited due to process rank 0 with PID 18180 on
node ahorn exiting improperly. There are two reasons this could occur:

1. this process did not call "init" before exiting, but others in
the job did. This can cause a job to hang indefinitely while it waits
for all processes to call "init". By rule, if one process calls "init",
then ALL processes must call "init" prior to termination.

2. this process called "init", but exited without calling "finalize".
By rule, all processes that call "init" MUST call "finalize" prior to
exiting or it will be considered an "abnormal termination"

This may have caused other processes in the application to be
terminated by signals sent by mpirun (as reported here).
--------------------------------------------------------------------------
hugo@ahorn:~/Documents/dev/elmerfem/elmerfem-dev/build$


cheers bernd
bernd
 
Posts: 9
Joined: 29 Nov 2016, 15:03

Re: compile and run on Debian Jessie

Postby bernd » 05 Dec 2016, 20:18

The file is in the sources and in build directory, but the solver does not find it.

Code: Select all
$ locate elements.def
/home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/elements.def
/home/hugo/Documents/dev/elmerfem/elmerfem-dev/elmerfem/fem/src/elements.def
/home/hugo/Documents/dev/elmerfem/elmerfem-release/build/fem/src/elements.def
/home/hugo/Documents/dev/elmerfem/elmerfem-release/elmerfem/fem/src/elements.def
$


seams because I have not set some variables ... ?! I did not install the binary. Could someone point me to a some documentation about what to do to run the elmer solver without installation.

Bernd
bernd
 
Posts: 9
Joined: 29 Nov 2016, 15:03

Re: compile and run on Debian Jessie

Postby Wil » 06 Dec 2016, 18:06

Please see:
http://www.elmerfem.org/forum/viewtopic ... 058#p15028

I used the following line before starting elmer but I think this is no more necessary:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/elmersolver

BR,
Wil
Wil
 
Posts: 57
Joined: 10 Jan 2014, 13:26
Location: Austria

Re: compile and run on Debian Jessie

Postby bernd » 06 Dec 2016, 19:10

Thanks for the answer, I'm a step further ...

I used:
Code: Select all

$ export ELMER_HOME=/home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src
$ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/modules


run my example
Code: Select all
$ mpirun -n 1   /home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/ElmerSolver_mpi   calculix_canti/case.sif
ELMER SOLVER (v 8.2) STARTED AT: 2016/12/06 17:08:03
ParCommInit:  Initialize #PEs:            1
MAIN:
MAIN: =============================================================
MAIN: ElmerSolver finite element software, Welcome!
MAIN: This program is free software licensed under (L)GPL
MAIN: Copyright 1st April 1995 - , CSC - IT Center for Science Ltd.
MAIN: Webpage http://www.csc.fi/elmer, Email elmeradm@csc.fi
MAIN: Version: 8.2 (Rev: 4fb13d7, Compiled: 2016-12-05)
MAIN: =============================================================
MAIN:
MAIN:
MAIN: -------------------------------------
MAIN: Reading Model: calculix_canti/case.sif
LoadInputFile: Scanning input file: calculix_canti/case.sif
LoadInputFile: Loading input file: calculix_canti/case.sif
Loading user function library: [ResultOutputSolve]...[ResultOutputSolver_Init0]
Loading user function library: [StressSolve]...[StressSolver_Init0]
ERROR:: LoadMesh: Requested mesh > ./. < does not exist!
--------------------------------------------------------------------------
mpirun has exited due to process rank 0 with PID 7427 on


ERROR:: LoadMesh: Requested mesh > ./. < does not exist!

attached the example I try to use.
Attachments
calculix_canti.zip
(19.73 KiB) Downloaded 39 times
bernd
 
Posts: 9
Joined: 29 Nov 2016, 15:03

Re: compile and run on Debian Jessie

Postby Wil » 06 Dec 2016, 20:29

Hi Bernd,
Please run the solver in the sub directory "calculix_canti".
Otherwise is the mesh defined in the header of case.sif (Mesh DB "." ".") not found.
Alternatively you can also specify the full directory-path there.
BR
Wil
Wil
 
Posts: 57
Joined: 10 Jan 2014, 13:26
Location: Austria

Re: compile and run on Debian Jessie

Postby bernd » 06 Dec 2016, 21:23

Wil wrote:Please run the solver in the sub directory "calculix_canti".
Otherwise is the mesh defined in the header of case.sif (Mesh DB "." ".") not found.


that did the trick ... Thanks.

Code: Select all
cd /home/hugo/Documents/projekte--BIM--opendev/dev--elmerfem/calculix_canti

# error, can not find elements.def
export ELMER_HOME=/home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src

# error, ResultOutputSolve: cannot open shared object file: No such file or directory
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/modules

mpirun -n 1   /home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/ElmerSolver_mpi   case.sif
bernd
 
Posts: 9
Joined: 29 Nov 2016, 15:03

Re: compile and run on Debian Jessie

Postby kataja » 07 Dec 2016, 13:03

Please look https://github.com/ElmerCSC/elmerfem/wiki/Compilation how to compile and install elmer solver.

Cheers,
Juhani
kataja
 
Posts: 56
Joined: 09 May 2014, 16:06

Re: compile and run on Debian Jessie

Postby bernd » 13 Dec 2016, 09:48

kataja wrote:Please look https://github.com/ElmerCSC/elmerfem/wiki/Compilation how to compile and install elmer solver.
thanks I was missing this.

BTW: how about run elmerfem without installation? What do you do when you do developing? Install after every compile?

I can run the example attached without installation by:
Code: Select all
cd /home/hugo/Documents/projekte--BIM--opendev/dev--elmerfem/calculix_canti
export ELMER_HOME=/home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/modules
mpirun -n 1   /home/hugo/Documents/dev/elmerfem/elmerfem-dev/build/fem/src/ElmerSolver_mpi   case.sif


Bernd

calculix_canti_1.zip
(11.42 KiB) Downloaded 45 times
bernd
 
Posts: 9
Joined: 29 Nov 2016, 15:03

Next

Return to Installation & compilation

Who is online

Users browsing this forum: No registered users and 1 guest