Mumps on Taito

Discussion about building and installing Elmer
Post Reply
rgladstone
Posts: 64
Joined: 15 Apr 2013, 16:23
Antispam: Yes

Mumps on Taito

Post by rgladstone »

Hi, I have a modified version of Elmer that I wish to use on Taito. I am able to install it fine on my Linux virtual machine on my laptop. I can install it without Mumps on Taito. If I try to install with Mumps on Taito I get this error:

Code: Select all

CMake Error at cmake/Modules/FindMumps.cmake:149 (MESSAGE):
  SCALAPACK library not found, required by Mumps.
Call Stack (most recent call first):
  CMakeLists.txt:161 (FIND_PACKAGE)
I am compiling like this:

Code: Select all

module load elmer-env
cmake ../elmerice/ -DWITH_Mumps:BOOL=TRUE -DWITH_ElmerIce:BOOL=TRUE -DWITH_Trilinos:BOOL=FALSE -DWITH_ELMERGUI:BOOL=FALSE -DCMAKE_INSTALL_PREFIX=/proj/project_2000339/elmer_FISOC
I guess it should be easy to overcome this error, since Elmer is often installed on Taito, and I don't think this error has anything to do with my changes to the code. Any suggestions?

Thanks,
Rupert
rgladstone
Posts: 64
Joined: 15 Apr 2013, 16:23
Antispam: Yes

Re: Mumps on Taito

Post by rgladstone »

bump...
tzwinger
Site Admin
Posts: 94
Joined: 24 Aug 2009, 12:20
Contact:

Re: Mumps on Taito

Post by tzwinger »

Hi Rupert,
This forum is not scanned for requests concerning CSC's computing platforms, instead I would ask you to send a request to CSC's servicedesk instead. Once you do, I will try to fix things. I guess you need the FISOC branch installed there.

Cheers,

Thomas
Post Reply