Error Messages when loading GUI

Discussion about building and installing Elmer
Post Reply
Jake
Posts: 4
Joined: 21 Aug 2015, 23:15
Antispam: Yes

Error Messages when loading GUI

Post by Jake » 30 Sep 2015, 01:08

Hi all,

I am getting three error messages when I load the Elmer GUI. It still loads up, but do you have nay idea where these are coming from, or if they are a problem?

Initialization file does not exist.

Material library does not exist.

Definitions file does not exist.


Would this explain why my non-interactive solver won't run without an error message?

I keep getting this message:

ERROR:: InitializeElementDescriptions: elements.def not found

Thank you!

Jake

kataja
Posts: 74
Joined: 09 May 2014, 16:06
Antispam: Yes

Re: Error Messages when loading GUI

Post by kataja » 30 Sep 2015, 10:17

Hi!

Try setting the environment variable ELMER_HOME point to directory where elmer is installed. For example if you have installed elmer in "c:\Program Files (x86)\Elmer", then ElmerSolver should be under "c:\Program Files (x86)\Elmer\bin" and ELMER_HOME should be "c:\Program Files (x86)\Elmer".

Hope this helps!

-Juhani

Jake
Posts: 4
Joined: 21 Aug 2015, 23:15
Antispam: Yes

Re: Error Messages when loading GUI

Post by Jake » 30 Sep 2015, 19:52

Juhani,

Thanks for your response! I assured that the ELMER_HOME variable was set to:

C:\Program Files (x86)\Elmer 8.0-Release

I didn't have an ElmerSolver variable listed, so I made a new ElmerSolver variable and set it to:

C:\Program Files (x86)\Elmer 8.0-Release\bin

Still no dice. Same messages and error :/

Jake

mzenker
Posts: 1964
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Error Messages when loading GUI

Post by mzenker » 01 Oct 2015, 10:57

Hi,

in my Elmer 7 installation (Windoze 7), I have ELMER_HOME as system variable, pointing to the Elmer installation directory, and %ELMER_HOME%\bin and %ELMER_HOME%\lib in my Path System variable. I don't know if this has changed in Elmer 8.
You don't need a variable called ElmerSolver. You just need to make sure that the elmersolver.exe file resides in %ELMER_HOME%\bin.

HTH,

Matthias

wing
Posts: 10
Joined: 14 Oct 2009, 11:49

Re: Error Messages when loading GUI

Post by wing » 27 Apr 2016, 17:07

I had the same ERROR:: InitializeElementDescriptions: elements.def not found problem recently and I confirmed that set ELMER_HOME to installation directory ($HOME/Apps/elmer in my case) solved the problem.

P.S. UBUNTU 16.04 64 bit, Elmersolver git Version: 8.2 (Rev: a095b95, Compiled: 2016-04-23)
and elmer launch script as below:

#!/bin/bash
export ELMER_HOME=$HOME/Apps/elmer
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$HOME/Apps/vtk/lib:$HOME/Apps/elmer/lib/ElmerGUI/ngcore:$HOME/Apps/elmer/lib/elmersolver
export PATH=$PATH:$HOME/Apps/vtk/bin:$HOME/Apps/elmer/bin
$HOME/Apps/elmer/bin/ElmerGUI

hope this helps.

kataja
Posts: 74
Joined: 09 May 2014, 16:06
Antispam: Yes

Re: Error Messages when loading GUI

Post by kataja » 27 Apr 2016, 17:22

Hi!

Apparently ElmerGUI uses variable ELMERGUI_HOME and it should point to "C:\Program Files (x86)\Elmer 8.0-Release\share\ElmerGUI".

-Juhani

Post Reply