cmake compile looks for *.ui files in the wrong place

Discussion about building and installing Elmer

cmake compile looks for *.ui files in the wrong place

Postby KaiMartin » 28 Feb 2015, 06:57

A cmake compile of a freshly cloned tree of Elmer+ElmerGUI failed for me with errors related to *.ui files.
Turned out, the make script for them looked in
../ElmerGUI/Application/src/
but they were actually located in
../ElmerGUI/Application/forms/

After I soft linked the files to the src folder ElmerGUI happily compiled. There was a similar error with ElmerGUItester which I resolved in the same way. With that in place I was able to compile Elmer with almost all optional components. The only exceptions were MATC and Trilinos. Trilinos is not in the Debian repo anymore. So no surprise there.

Is searching for *.ui files in the wrong folder a known issue? Should I file a bug report?

kmk
---<)kaimartin(>---
KaiMartin
 
Posts: 24
Joined: 02 Jun 2013, 00:07
Location: Hannover, Germany

Re: cmake compile looks for *.ui files in the wrong place

Postby dekoder87 » 13 Mar 2015, 04:33

Hi kmk,

Thank You for that information it was very helpful.

Jacek
dekoder87
 
Posts: 31
Joined: 22 Oct 2014, 19:42
Location: United Kingdom

Re: cmake compile looks for *.ui files in the wrong place

Postby dvlierop » 16 Jan 2016, 00:09

Confirmed! The problem is still there, and copying or linking the files into the right directory nicely works around this.

I've spent quite a bit of time on this to find a proper solution, but I still don't understand though how this is supposed to work. Is it possible at all using CMAKE to store the forms in a separate directory?

See also this feature request for CMAKE: http://public.kitware.com/Bug/view.php?id=15227

For the record, I've been trying this on Ubuntu 15.10 and 16.04 alpha, both having CMAKE 3.2.2
dvlierop
 
Posts: 12
Joined: 16 Feb 2011, 23:21

Re: cmake compile looks for *.ui files in the wrong place

Postby KaiMartin » 04 Apr 2016, 23:41

I just did a fresh build on Debian testing (stretch). The *.ui files are still located in the folder Application/forms. But cmake of ElmerGUI did not need the symlinks anymore.

However, ElmerGUItester still requires a fix:
Code: Select all
ln -s ../elmerfem/ElmerGUItester/forms/mainform.ui ../elmerfem/ElmerGUItester/src/mainform.ui


---<)kaimartin(>---
---<)kaimartin(>---
KaiMartin
 
Posts: 24
Joined: 02 Jun 2013, 00:07
Location: Hannover, Germany

Re: cmake compile looks for *.ui files in the wrong place

Postby DobesJ88 » 19 Dec 2016, 14:24

Hello to everyone,
I have got the same error during compilation Elmer software on the OpenSUSE 13.2 system software.
which file I have to modify to fix this error?
thank you
DobesJ88
 
Posts: 5
Joined: 18 Dec 2016, 04:22

Re: cmake compile looks for *.ui files in the wrong place

Postby DobesJ88 » 19 Dec 2016, 16:12

Hello again,
if I try to compile Elmer on OpenSuse software I gave this error:

Code: Select all
libelmersolver.so: undefined reference to `mpi_comm_split_'
collect2: error: ld returned 1 exit status
fem/src/CMakeFiles/Solver_TGT.dir/build.make:89: návod pro cíl „fem/src/ElmerSolver“ selhal
make[2]: *** [fem/src/ElmerSolver] Chyba 1
CMakeFiles/Makefile2:630: návod pro cíl „fem/src/CMakeFiles/Solver_TGT.dir/all“ selhal
make[1]: *** [fem/src/CMakeFiles/Solver_TGT.dir/all] Chyba 2
make[1]: *** Čeká se na nedokončené úlohy…
Linking Fortran executable GebhardtFactors
libelmersolver.so: undefined reference to `mpi_comm_split_'
collect2: error: ld returned 1 exit status
fem/src/CMakeFiles/GebhardtFactors.dir/build.make:99: návod pro cíl „fem/src/GebhardtFactors“ selhal
make[2]: *** [fem/src/GebhardtFactors] Chyba 1
CMakeFiles/Makefile2:587: návod pro cíl „fem/src/CMakeFiles/GebhardtFactors.dir/all“ selhal
make[1]: *** [fem/src/CMakeFiles/GebhardtFactors.dir/all] Chyba 2
Linking Fortran executable ViewFactors
Linking Fortran shared library ArtificialCompressibility.so
libelmersolver.so: undefined reference to `mpi_comm_split_'
collect2: error: ld returned 1 exit status
fem/src/CMakeFiles/ViewFactors.dir/build.make:101: návod pro cíl „fem/src/ViewFactors“ selhal
make[2]: *** [fem/src/ViewFactors] Chyba 1
CMakeFiles/Makefile2:675: návod pro cíl „fem/src/CMakeFiles/ViewFactors.dir/all“ selhal
make[1]: *** [fem/src/CMakeFiles/ViewFactors.dir/all] Chyba 2
[ 83%] Built target ArtificialCompressibility
Linking Fortran shared library AdvectionReaction.so
[ 83%] Built target AdvectionReaction
Linking Fortran shared library ArteryOutlet.so
[ 83%] Built target ArteryOutlet
Linking Fortran shared library AdvectionDiffusion.so
[ 83%] Built target AdvectionDiffusion
Linking Fortran shared library Acoustics.so
[ 83%] Built target Acoustics
Makefile:147: návod pro cíl „all“ selhal
make: *** [all] Chyba 2


Can you anybody help with this? Many thanks
DobesJ88
 
Posts: 5
Joined: 18 Dec 2016, 04:22


Return to Installation & compilation

Who is online

Users browsing this forum: No registered users and 4 guests

cron