Problem with hypre, Install Elmer/Ice on Ubuntu 18.04 LTS

Discussion about building and installing Elmer
Post Reply
i_like_glaciers
Posts: 2
Joined: 23 Aug 2019, 15:23
Antispam: Yes

Problem with hypre, Install Elmer/Ice on Ubuntu 18.04 LTS

Post by i_like_glaciers » 23 Aug 2019, 15:53

Dear community,

I have a problem with the installation of Elmer/Ice on Ubuntu 18.04. A problem I don't remember to have run in on Ubuntu 14.04 and 16.04.

I followed the instructions here http://elmerfem.org/elmerice/wiki/doku. ... ationcmake, creating a bash that executes all the cmake commands.

The compilation/installation interrupts at a certain point (the hypre packages), giving me the following error message:

CMake Error at cmake/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
Could NOT find Hypre (missing: Hypre_INCLUDE_DIR)
Call Stack (most recent call first):
cmake/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
cmake/Modules/FindHypre.cmake:74 (find_package_handle_standard_args)
CMakeLists.txt:280 (FIND_PACKAGE)


I'm quite positive I have all the required packages, although I have more the impression that the problem is with the linkage/paths. Until now I couldn't figure out what exactly the problem is.
I'm happy about any kind of help.

I'm neither an Ubuntu- nor an Elmer-pro. Please bear with me.

Thank you and best regards

kevinarden
Posts: 246
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Problem with hypre, Install Elmer/Ice on Ubuntu 18.04 LTS

Post by kevinarden » 24 Aug 2019, 12:01

looks like the variable Hypre_INCLUDE_DIR is not defined in the cmake or defined incorrectly. This user had a similar problem

viewtopic.php?f=2&t=5548&p=18808&hilit= ... DIR#p18808

kevinarden
Posts: 246
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Problem with hypre, Install Elmer/Ice on Ubuntu 18.04 LTS

Post by kevinarden » 25 Aug 2019, 00:15

I was able to do it with

cmake -DWITH_ElmerIce:BOOL=TRUE -DWITH_ELMERGUI:BOOL=FALSE -DWITH_MPI:BOOL=TRUE -DCMAKE_INSTALL_PREFIX=../install ../elmerfem

following instructions for compileing on https://www.csc.fi/web/elmer/sources-and-compilation

This only gives you ElmerSolver with ElmerIce include
in the directory

./elmer/install

my main elemer tool is installed with

sudo apt-add-repository ppa:elmer-csc-ubuntu/elmer-csc-ppa
sudo apt-get --allow-unauthenticated upgrade
sudo apt-get install elmerfem-csc-eg

which gives ElmerGUI, regular ElmerSolver, and ElmerGrid

If I need ElmerIce I point the solver to the compiled version in the sif file

Alternatively you could replace the /usr/lib/elmersolver with the
./elmer/install/lib/elmersolver

then the Ice solvers would be available to the default ElmerSover

i_like_glaciers
Posts: 2
Joined: 23 Aug 2019, 15:23
Antispam: Yes

Re: Problem with hypre, Install Elmer/Ice on Ubuntu 18.04 LTS

Post by i_like_glaciers » 01 Oct 2019, 16:39

Thank you kevinarden for your response.

I was able to do do the installation with the help of your post.

But I had to install everything individually.
First the MPI, then the HYPRE, then the Elmer/Ice.
I couldn't use a cmake-file that does everything at once, as recommended here: http://elmerfem.org/elmerice/wiki/doku. ... ationcmake

And I think at the moment I cannot go parallel.
But I haven't checked yet properly.

Post Reply