Elmer installation in Lubuntu 18.10 by ''apt-get install''

Discussion about building and installing Elmer
Post Reply
joellapointe1717
Posts: 2
Joined: 09 Feb 2019, 02:15
Antispam: Yes

Elmer installation in Lubuntu 18.10 by ''apt-get install''

Post by joellapointe1717 » 09 Feb 2019, 02:33

Hi,

I tried the following to install Elmer with the gui :

Code: Select all

$ sudo apt-add-repository ppa:elmer-csc-ubuntu/elmer-csc-ppa
$ sudo apt-get update
$ sudo apt-get install elmerfem-csc
It did the following errors :

Code: Select all

root@lubuntu:~# apt-add-repository ppa:elmer-csc-ubuntu/elmer-csc-ppa Archive for the monolithic Elmer FEM software ubuntu packages.
 More info: https://launchpad.net/~elmer-csc-ubuntu/+archive/ubuntu/elmer-csc-ppa
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Réception de:1 http://security.ubuntu.com/ubuntu cosmic-security InRelease [88,7 kB]
Atteint:2 http://archive.ubuntu.com/ubuntu cosmic InRelease         
Ign:3 http://ppa.launchpad.net/elmer-csc-ubuntu/elmer-csc-ppa/ubuntu cosmic InRelease
Atteint:4 http://archive.canonical.com/ubuntu cosmic InRelease      
Réception de:5 http://archive.ubuntu.com/ubuntu cosmic-updates InRelease [88,7 kB]
Err:6 http://ppa.launchpad.net/elmer-csc-ubuntu/elmer-csc-ppa/ubuntu cosmic Release
  404  Not Found [IP : 91.189.95.83 80]
Réception de:7 http://archive.ubuntu.com/ubuntu cosmic-backports InRelease [74,6 kB]
Lecture des listes de paquets... Fait                           
E: Le dépôt http://ppa.launchpad.net/elmer-csc-ubuntu/elmer-csc-ppa/ubuntu cosmic Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
root@lubuntu:~# apt-get update
Atteint:1 http://archive.ubuntu.com/ubuntu cosmic InRelease
Réception de:2 http://security.ubuntu.com/ubuntu cosmic-security InRelease [88,7 kB]
Atteint:3 http://archive.canonical.com/ubuntu cosmic InRelease      
Ign:4 http://ppa.launchpad.net/elmer-csc-ubuntu/elmer-csc-ppa/ubuntu cosmic InRelease
Réception de:5 http://archive.ubuntu.com/ubuntu cosmic-updates InRelease [88,7 kB]
Err:6 http://ppa.launchpad.net/elmer-csc-ubuntu/elmer-csc-ppa/ubuntu cosmic Release
  404  Not Found [IP : 91.189.95.83 80]
Réception de:7 http://archive.ubuntu.com/ubuntu cosmic-backports InRelease [74,6 kB]
Lecture des listes de paquets... Fait                           
E: Le dépôt http://ppa.launchpad.net/elmer-csc-ubuntu/elmer-csc-ppa/ubuntu cosmic Release n'a pas de fichier Release.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
root@lubuntu:~# apt-get install elmerfem-csc
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet elmerfem-csc
Then, I tried to compile with instructions comming from https://www.csc.fi/web/elmer/sources-and-compilation.
I was at 60%, this error appened :

Code: Select all

[ 60%] Building Fortran object fem/src/CMakeFiles/elmersolver.dir/DefUtils.F90.o                                                          
/home/joel/elmer/elmerfem/fem/src/DefUtils.F90:3221:11:

     SOL => x % Values
           1
Error: Assignment to contiguous pointer from non-contiguous target at (1)
make[2]: *** [fem/src/CMakeFiles/elmersolver.dir/build.make:882: fem/src/CMakeFiles/elmersolver.dir/DefUtils.F90.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:649: fem/src/CMakeFiles/elmersolver.dir/all] Error 2
make: *** [Makefile:163: all] Error 2
I realy would like to try elmer, it seems to be a quality FEA software. However, whatever the manner I try to install it is problematic. I vividly recomment to elmer team to do an universal appimage so elmer become universally usable on any linux distro and no install is needed.

Thank you!

Joel Lapointe

kevinarden
Posts: 215
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Elmer installation in Lubuntu 18.10 by ''apt-get install''

Post by kevinarden » 09 Feb 2019, 12:35

they do that via;

Virtual machine
There is a Linux Mint based virtual machine (VM) available at
http://www.nic.funet.fi/pub/sci/physics ... alMachines

The VM is huge in size but provides a certified user experience. This is often used at courses to give not only a fresh Elmer version, but also a complete installation of related tools.

kevinarden
Posts: 215
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Elmer installation in Lubuntu 18.10 by ''apt-get install''

Post by kevinarden » 09 Feb 2019, 12:44

Which compiler are you using for FORTRAN?

kevinarden
Posts: 215
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Elmer installation in Lubuntu 18.10 by ''apt-get install''

Post by kevinarden » 09 Feb 2019, 13:11

I load this operating system in a virtual machine and tried the install, this system is using apt-secure and since there is no release file in the repository it is disabled by default, you can by pass the disable on apt-get by using the option

Pass the --allow-unauthenticated option to apt-get as in:

sudo apt-get --allow-unauthenticated upgrade

joellapointe1717
Posts: 2
Joined: 09 Feb 2019, 02:15
Antispam: Yes

Re: Elmer installation in Lubuntu 18.10 by ''apt-get install''

Post by joellapointe1717 » 10 Feb 2019, 06:16

I did the --allow-unauthenticated upgrade whitout sucess!

kevinarden
Posts: 215
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Elmer installation in Lubuntu 18.10 by ''apt-get install''

Post by kevinarden » 10 Feb 2019, 16:29

older compilers only issued a warning for that condition my gcc is version 7.3

Also there is a CAELINUX iso that can be run in a VM or livecd, it has elmer and many other fea tools

mzenker
Posts: 1936
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Elmer installation in Lubuntu 18.10 by ''apt-get install''

Post by mzenker » 11 Feb 2019, 13:12

Hi,

did you try to install elmer-csc-eg (not elmer-csc)?
It seems that at least under Ubuntu 18.04 the installation from ppa works, see here.

@Elmer team: is it possible that binaries for Ubuntu 18.10 are not (yet) configured in the ppa?

Matthias

andrew898
Posts: 1
Joined: 13 Aug 2019, 12:43
Antispam: Yes

Re: Elmer installation in Lubuntu 18.10 by ''apt-get install''

Post by andrew898 » 13 Aug 2019, 13:15

I am also looking for this and the above-mentioned suggestions helped me a lot to get all kind of ideas regarding this module and if in case, you need more suggestions, you may directly consult with Canon Error 801 that assist you better.

Post Reply