Elmer installation problem

Discussion about building and installing Elmer
Post Reply
Nanga
Posts: 1
Joined: 04 Jul 2019, 13:43
Antispam: Yes
Location: sweden

Elmer installation problem

Post by Nanga » 04 Jul 2019, 13:50

Hi,

I would like to install Elmer on Ubuntu 12.04 but I have some problems. First of all I compiled the elmer source packages in the following order:matc, umfpack, mathlibs, elmergrid, meshgen2d, eio, hutiter, fem, using the normal procedure of ./configure, make, make install, as suggested in the Elmer official homepage. Then, I installed all the optional components to compile ElmerGUI. I used the following library: libfreetype6 and libfreetype6-dev (FREETYPE 2.4.1.0), libfreeimage-dev (FREE IMAGE 3.14.1), libftgf2 (FTGL 2.13), libgl2ps-dev (GL2PS 1.3.5), python-qt4 (PYTHON-QT), libtet1.4.2, libtet1.4.2-dev, tetge (TETGEN 1.4.2), libtbb-dev, libtbb-doc (TBB 4.1.2), Qwt-6.1, Qt 4.8, and vtk-5.8.

When I try to configure ElmerGUI I obtain the following errors:

Code: Select all

tmp/glwidget.o:glwidget.cpp:function GLWidget::changeProjection(): error: undefined reference to 'gluPerspective' 
tmp/glwidget.o:glwidget.cpp:function GLWidget::resizeGL(int, int): error: undefined reference to 'gluPerspective' 
tmp/glwidget.o:glwidget.cpp:function GLWidget::mouseDoubleClickEvent(QMouseEvent*): error: undefined reference to 'gluPickMatrix' 
tmp/glwidget.o:glwidget.cpp:function GLWidget::drawCoordinates(): error: undefined reference to 'gluCylinder' 
tmp/glwidget.o:glwidget.cpp:function GLWidget::drawCoordinates(): error: undefined reference to 'gluCylinder' 
tmp/glwidget.o:glwidget.cpp:function GLWidget::drawCoordinates(): error: undefined reference to 'gluCylinder' 
tmp/glwidget.o:glwidget.cpp:function GLWidget::GLWidget(QWidget*): error: undefined reference to 'gluNewQuadric' 
collect2: ld returned 1 exit status 
make[1]: *** [ElmerGUI] Error 1 
make[1]: Leaving directory `/home/silvia/trunk/ElmerGUI/Application' 
make: *** [sub-Application-make_default] Error 2 
Because of the missing reference to a type I supposed that the error could be a missing inclusion in the source code, so I searched on the web and found out that glu* types (where * stands for "anything" and not for pointer ) are defined in glu.h; so I added this line at the top of glwidget.h file: #include <GL/glu.h>
I've cleaned the source folder and rebuilt all, but I still have the same errors.
Any suggestion?

Thank you in advance.

mzenker
Posts: 1955
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Elmer installation problem

Post by mzenker » 04 Jul 2019, 15:03

Hi,

Ubuntu 12.04 is 7 years old and not supported any more. I would suspect old compiler/library versions to be at least a part of the problems you have to compile the current Elmer sources. Normally precompiled Elmer binaries for Ubuntu can be found on launchpad, see here: viewtopic.php?f=2&t=1#p19826. But there is no package for Ubuntu12 as far as I have seen.
So I would serioisly consider updating your Ubuntu. You might also run into other types of problems with such an old linux (e.g. recent versions of Mozilla Firefox are not available) ...

HTH,
Matthias

Post Reply