Homebrew Installation Fails

Discussion about building and installing Elmer

Homebrew Installation Fails

Postby NGeorgescu » 16 Apr 2018, 23:45

On Homebrew 1.6.1 (MacOS 10.13.4), using
Code: Select all
brew install elmercsc/elmerfem/elmer


it kicks back the error:
Code: Select all
Error: Calling 'depends_on :mpi' is disabled!
Use 'depends_on "open-mpi"' instead.
/usr/local/Homebrew/Library/Taps/elmercsc/homebrew-elmerfem/elmer.rb:22:in `<class:Elmer>'
Please report this to the elmercsc/elmerfem tap!
Or, even better, submit a PR to fix it!
If reporting this issue please do so at (not Homebrew/brew or Homebrew/core):
  https://github.com/elmercsc/homebrew-elmerfem/issues


This seems totally asinine. Is there a way to get around this or am I stuck?

Thanks,
NSG
NGeorgescu
 
Posts: 1
Joined: 16 Apr 2018, 23:36

Re: Homebrew Installation Fails

Postby kataja » 20 Apr 2018, 09:26

Run
Code: Select all
brew update
and try again. Please let us know if it still fails.
kataja
 
Posts: 67
Joined: 09 May 2014, 16:06


Return to Installation & compilation

Who is online

Users browsing this forum: No registered users and 2 guests

cron