Make install fails to tests ???

Clearly defined bug reports and their fixes
Post Reply
joni
Posts: 21
Joined: 10 Mar 2018, 15:05
Antispam: Yes

Make install fails to tests ???

Post by joni » 05 Mar 2019, 14:23

make install

========

-- Up-to-date: /mpi/S5/builddir/ELMER-LINUX_v2/elmertests/diffuser_v2f/diffuser/./channel.dat
-- Installing: /mpi/S5/builddir/ELMER-LINUX_v2/elmertests/findnorm.c
CMake Error at fem/tests/cmake_install.cmake:97 (file):
file INSTALL cannot find
"/mpi/S5/elmerfem/fem/tests/ElmerSolver_test_how-to.txt".
Call Stack (most recent call first):
fem/cmake_install.cmake:47 (include)
cmake_install.cmake:46 (include)


========


I can not figure ot where this comes elmertests/findnorm.c

findnorm.c is not found from source package ???

========

If need make files , just note me!

joni
Posts: 21
Joined: 10 Mar 2018, 15:05
Antispam: Yes

Re: Make install fails to tests ???

Post by joni » 05 Mar 2019, 16:45

ok, it dose not come if I change libraryes,... switch off mpi

it prevents installation of binaryes.

raback
Site Admin
Posts: 3448
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: Make install fails to tests ???

Post by raback » 06 Mar 2019, 12:12

Hi joni,

The file "findnorm.c" is not needed any more. Actually it has not been part of the devel repo since 2-3 years when we started using ctest for testing. At that time we also gave up on gnu autotools. Thus, I would think that findnorm.c reference must come from your own setup.

-Peter

Post Reply