Page 1 of 2

Elmer crash when clicking on boundaries

Posted: 05 Jul 2018, 11:04
by Roland
I have downloaded Elmer 8.3-98dec6e6 version.
The loading of a project works, but when clicking on a boundary for setting the boundary conditions, it does not turn the selected boundary in red color, the "set boundary properties" box opens partially and after a few seconds Elmer crashes and closes.
Has anybody the same problem and is there an idea for fixing this bug?
Thanks for your help.

Re: Elmer crash when clicking on boundaries

Posted: 08 Jul 2018, 18:06
by raback
Hi Roland,

Does the problem related only to a case that is reloaded, or also to some cases where you start from the mesh description only?

I just opened some mesh/CAD files with a fresh Windows version (wire.grd and pump_carter_sup.stp) and can select entities there. Could the problem lie in restarting from files generated by a previous version?


Re: Elmer crash when clicking on boundaries

Posted: 23 Aug 2018, 04:33
by schweb
Hi Roland,

I have exactly the same problem.
In detail I have installed the software, 8.2 and 8.3 on my personal laptop and works perfectly.
The other computer I use is at work where both versions show the same double click problem as you mentioned.

Is a solution available as yet?

Both computers have Win10 64-bit.
I tried many things without a successful outcome, such as:

1- run compatibility mode to win7.
2- reboot after installation
3- check firewall and antivirus
4- run as admin
5- run windows troubleshooting
6- import a simpler geometry file, like a block.
7- change project directory to C:\a\ to avoid spaces in the path etc.
8- changed Elmer's root directory to C:\Elmer8.3-c30fff2\bin (no spaces) and updated environment variables.

Help! :)

Thanks in advance


Re: Elmer crash when clicking on boundaries

Posted: 18 Sep 2018, 16:57
by Phlix

I have the same problem.
When I installed Elmer 8.3-98dec6e6 a few weeks ago everything was working regarding this topic.
(I conducted the wire tutorial and similar simulations)

I did not do an Update or anything related. Out of nowhere this error occurred.

Now I reinstalled Elmer, downloaded the newest modified version (elmerfem-nightly_Windows-AMD64.exe 12-Sep-2018 00:33 84M)
but still Elmer crashes if the boundaries are selected manually.
I tried several projects and in all it's the same :(

Sometimes when I hit a boundary (before Elmer crashes) in the lower left corner of ElmerGUI the string "Error: Boundary Index mismatch" occours.

Is there any known reason for this error? Or even a solution?

Best regards,


Re: Elmer crash when clicking on boundaries

Posted: 18 Sep 2018, 17:28
by mzenker

AFAIR the boundary selection in 3D has never worked correctly in ElmerGUI. There is no real solution for that, except fix the bug in the code...
The problem is that ElmerGUI is not really actively maintained, since the Elmer team has limited (wo)manpower and concentrates on the FEM engine, i.e. the solver.
So if there is a C++ hero out there who wants to devote some time, (s)he is free to get the code and fix it... ;)

There is kind of a workaround to find out the boundary number for 3D meshes: do it outside ElmerGUI using gmsh. Here is how to do it: When the mesh is imported in ElmerGUI, do "save project". Then go to the project directory with a command line terminal (DOS box in Windoze) and say

ElmerGrid 2 4 mesh

This will generate a file mesh.msh which can be opened in gmsh and has the same numbering as the Elmer mesh. In gmsh you can view the mesh and find out the boundary numbers much more comfortably than in ElmerGUI.


Re: Elmer crash when clicking on boundaries

Posted: 03 Oct 2018, 15:18
by Phlix

Thank you very much for this nice workaround!

As much as I would like to be the one unfortunately, as so far, I am not this C++ hero we are looking for because my skills are only limited in this field...
But things can always change... or hope dies last that there will rise one C++ hero who will take the challenge. ;)

I would like to delimit this problem further and have 2 more questions regarding this topic.

When I start the ElmerGUI logger I get the following crash report:

Code: Select all

Filetype determined by suffix: 8
Initialized the filetype
Regenerating and saving the solver input file...
SifGenerator: Body index out of bounds
SifGenerator: Body index out of bounds
SifGenerator: Body index out of bounds
boundaryConditions:  () 
Selected surface 8
Process error
Error: Crashed
Process state changed
State: NotRunning
Exit code: -1073741819
Status: CrashExit

Note: Immediately after I've loaded the project files (and before I selected a surface ->in this case surface 8), the boundaryConditions:() are already colored in red.

1. Where can I check what the meaning is of Exit code: -1073741819 is?

2. Usually I am meshing my geometries with Salome. Is there a way that the Face Numbers in Salome (Mesh_1 -> Groups of Faces) coincide with the Numbers in Elmer? Or is this advantage of equality only limited to Gmsh and Elmer? :roll:

Best regards

Re: Elmer crash when clicking on boundaries

Posted: 04 Oct 2018, 10:56
by mzenker

1. I don't know. Sometimes the problem goes away if you do the mesh import with the -autoclean option. In ElmerGUI, you can add it to the ElmerGrid String under mesh->configure. OR you use the command line, see below.
2. You can never be sure that body/boundary numbers are kept when importing a mesh to Elmer. That is why the workaraound consists in converting the already imported mesh back to gmsh. This export option in ElmerGrid keeps the numbering.
If you use Salome, you can also do the mesh conversion on the command line:

ElmerGrid 8 2 mymesh.unv -autoclean

ElmerGrid will write the correspondence between Salome names and Elmer numbers into the terminal, and will also generate a file mesh.names where it can be looked up.


Re: Elmer crash when clicking on boundaries

Posted: 05 Oct 2018, 23:25
by raback

Matthias has explained how it is. Thanx! We have a full project portfolio until the end of the year but none of them relates to ElmerGUI. We have done some smaller modifications to ElmerGUI when there has been more ample time but that's all. We are not too happy about this and there is certainly a small project for a Qt/C++ wizard.


Re: Elmer crash when clicking on boundaries

Posted: 11 Oct 2018, 01:43
by Doug
Hello all

I'm brand new to Elmer and experienced the same problem trying to run the first tutorial. ElmerGUI suffers a fatal crash after every double click selection, seemingly without fail. I'm running Elmer 8.3-c30fff2 on 64 bit Windows 10 platform with MPI. ElmerGUI log reports "Process Error: Crashed immediately after (any) surface has been selected. Is there an older version or different installation option that doesn't have this bug?


Re: Elmer crash when clicking on boundaries

Posted: 11 Oct 2018, 11:14
by mzenker

do you use a nightly build or the release version?
I don't have those crashes at the moment under Windows 7 using a nightly build dated 2018-08-01.
If the crashes persist, all you can do is not to doubleclick on your mesh, export it to gmsh and examine it there as described above.