[SOLVED] VTU export fails

Clearly defined bug reports and their fixes

[SOLVED] VTU export fails

Postby ivanov » 02 Sep 2016, 10:15

Elmer Version: 8.2 (Rev: 026c3a7, Compiled: 2016-09-02)
Linux Ubuntu 16.04.1 LTS

Example of code: https://www.dropbox.com/s/upi230hu75r8d ... t.zip?dl=0

An attempt to write result to VTU format fails with a following output:

Code: Select all
SingleSolver: Solver Equation string is: internalvtuoutputsolver
ResultOutputSolver: -------------------------------------
ResultOutputSolver: Working on mesh: mesh
ResultOutputSolver: Dimension of mesh is: 3
ResultOutputSolver: Saving in unstructured VTK XML (.vtu) format
VtuOutputSolver: Number of active elements 168100 out of 168100
VtuOutputSolver: Number of geometry nodes 26624 out of 26624
VtuOutputSolver: Full filename base is: ./mesh/result
VtuOutputSolver: Setting offset for boundary entities: 100
VtuOutputSolver: Writing the vtu file: ./mesh/result0010.vtu
AscBinWriteInit: Initializing buffered ascii/binary writing
AscBinWriteInit: Writing in binary
AscBinWriteInit: Writing in double precision
AscBinWriteInit: Writing to unit number: 58
AscBinWriteInit: Size of buffer is: 168100
WARNING:: WriteVtuFile: Are there really no scalars or vectors?
VtuOutputSolver: Writing nodal fields
VtuOutputSolver: Number of nodal fields written: 0
VtuOutputSolver: Writing elemental fields
VtuOutputSolver: Number of elemental fields written: 0
VtuOutputSolver: Writing entity IDs for bodies and boundaries
VtuOutputSolver: Writing coordinates for each used node
VtuOutputSolver: Writing the elemental connectivity data
VtuOutputSolver: Writing nodal fields
VtuOutputSolver: Writing elemental fields
AscBinWriteInit: Terminating buffered ascii/binary writing

VTU export does not work either with internal internalvtuoutputsolver or ResultOuputSolve solver. The same code worked fine before updating the revision from git.
Last edited by ivanov on 05 Sep 2016, 10:20, edited 1 time in total.
Posts: 11
Joined: 25 Aug 2014, 12:51

Re: VTU export fails

Postby raback » 02 Sep 2016, 23:24


I just compiled a fresh version on LinuxMint and run your problem on it. Everything went ok, and I was able to visualize all the fields with Paraview.

However, I think I may have found a problem in an uninitialized variable. This is now fixed in devel branch. Maybe you can give it a try.

Thanx for reporting!
Site Admin
Posts: 3211
Joined: 22 Aug 2009, 11:57
Location: Espoo, Finland

[SOLVED] Re: VTU export fails

Postby ivanov » 05 Sep 2016, 10:19

Hi Peter,

It's fixed indeed! Everything works fine. Thank you.

Posts: 11
Joined: 25 Aug 2014, 12:51

Return to Bug reports

Who is online

Users browsing this forum: No registered users and 2 guests