Harmonic Analysis: possible Bug in VTU exporter

Clearly defined bug reports and their fixes
Post Reply
CrocoDuck
Posts: 44
Joined: 12 May 2016, 13:15
Antispam: Yes

Harmonic Analysis: possible Bug in VTU exporter

Post by CrocoDuck » 15 Aug 2016, 15:22

Hi. When running Linear Elasticity Harmonic Analysis the VTU exported file appears to have poor data that does not compare to the solution as viewed in ElmerPost.
  • Running Elmer on Arch Linux amd64, installed through AUR (compilation and installation commands scripted in the PKGBUILD).
  • Elmer Version: 8.2, Compiled: 2016-06-23
Here a comparison of how the Harmonic Analysis solution appear in ElmerPost end ParaView respectively:

Image

Image

The problem can be reproduced also by setting case.vtu as Post File in the Simulation parameters. I am not sure whether it is a bug or me doing something wrong, but I am getting crazy around this for a week without finding anything wrong. I guess it could be something wrong with ParaView as well but I lack the experience to make sure about it.

See attached file with minimal example:
elasticity-harm-test.zip
(1.18 MiB) Downloaded 94 times
.

raback
Site Admin
Posts: 3305
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: Harmonic Analysis: possible Bug in VTU exporter

Post by raback » 17 Aug 2016, 13:04

Hi CrocoDuck

Thanx for reporting! There is indeed some challenge to get it to work. The feature uses the same parts of the code as the eigenmode part but you have to add a keyword to make it work to the Solver section

Code: Select all

  Harmonic System Values = Integer 1
Now since few minutes this has bee fixed in the devel branch. Also the naming is improved. So if you recompile your case should work as is.

-Peter

CrocoDuck
Posts: 44
Joined: 12 May 2016, 13:15
Antispam: Yes

Re: Harmonic Analysis: possible Bug in VTU exporter

Post by CrocoDuck » 18 Aug 2016, 11:24

Hi Peter, thank you very much! I will test the devel branch at my earliest occasion and report back.

Post Reply