Elmer 8.1 Windows binaries: solver modules not found

Clearly defined bug reports and their fixes
Post Reply
mzenker
Posts: 1747
Joined: 07 Dec 2009, 11:49
Location: Germany

Elmer 8.1 Windows binaries: solver modules not found

Post by mzenker » 09 Dec 2015, 19:31

Hi,

just to place the bug report in the appropriate forum:

It seems that the Elmer 8.1 binary distribution for Windows does not work properly (at least under under Windows 7).
Elmersolver does not find the solver module dlls although the environment variables are properly set. It seems that the search path string is truncated inside the solver.
See here for details: viewtopic.php?f=2&t=4120

Elmer 8.0 does not have that problem.

Matthias

mark smith
Posts: 194
Joined: 26 Aug 2009, 18:20
Location: Peterborough, England

Re: Elmer 8.1 Windows binaries: solver modules not found

Post by mark smith » 10 Dec 2015, 20:42

HI,
I had a similar problem with 8.0 on windows 7, when calling elmergrid or elmersolver from a cmd window, widows reported that they were not recognised as an internal or external command, my PATH system variable had not been updated to include the elmer\bin directory, when I added this manually all was OK.
Regards
Mark

mzenker
Posts: 1747
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Elmer 8.1 Windows binaries: solver modules not found

Post by mzenker » 11 Dec 2015, 11:50

Hi,

this problem is different: The PATH is OK, the solver starts (called by ElmerGUI), it just complains that it doesn't find the solver modules - but the string it takes as search path seems somehow truncated: The "C:" is missing.
Elmer 8.0 runs OK on my machine.

Matthias

Post Reply