Missing convergence view in ElmerGUI

Clearly defined bug reports and their fixes
Post Reply
thomasatelmer
Posts: 27
Joined: 18 Jan 2019, 18:18
Antispam: Yes

Missing convergence view in ElmerGUI

Post by thomasatelmer » 21 Oct 2019, 00:36

Hi everybody,

using the package 8.4-0ppa0-201910201433~e0cf990~ubuntu18.04.1 from launchpad (= elmerfem-csc-eg) I installed Elmer along with ElmerGUI. I am missing a menu entry for switching the convergence view on and off. Unfortunately, the window is always not showing; I could live with it coming each time the solver is started.
I attached a screenshot of what the menu in ElmerGUI comes out to be using said package:
menus.png
menus.png (24.84 KiB) Viewed 269 times
I would really like to use the convergence view - similar to an old saying: "a picture says more than a thousand lines of log" :lol:

Thank you,
Thomas.

thomasatelmer
Posts: 27
Joined: 18 Jan 2019, 18:18
Antispam: Yes

Re: Missing convergence view in ElmerGUI

Post by thomasatelmer » 27 Oct 2019, 22:58

Hi and good evening,

here is some small update to this issue on my side. I figured out in the source that the convergence view uses QWT library and therefore installed QWT runtime package on my machine from Launchpad. Before that activity I uninstalled said Elmer package and reinstalled it afterwards. Unfortunately, the result was not anything different from before :?

Any help or hints greatly appreciated...

Thomas.

kevinarden
Posts: 290
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Missing convergence view in ElmerGUI

Post by kevinarden » 01 Nov 2019, 23:43

I have the same condition on Linux 19.2 and also can not find a solution.

I tried to compile my own ElmerGUI (12th unsuccessful try, can never get through the process). To get past the dependencies (inluded *.h) files I had to install Qt and then use Qt to install qwt 6. For Qt the version is on 15, the ElmerGUI directions say Qt version 4.8, which is no longer available. The oldest I could get back to was 5.9 and it had the same results as version 15. After all of the include libraries were resolved the compile did not finish because of reported code errors in the ElmerGUI code. I assume they are not errors but a compatibility issue with a much later version of Qt, since the compiler suggested slightly different syntax for the code in question.

It may be possible that an incompatibility with newer libraries of qwt on the latest versions of UBUNTU is causing this error.

thomasatelmer
Posts: 27
Joined: 18 Jan 2019, 18:18
Antispam: Yes

Re: Missing convergence view in ElmerGUI

Post by thomasatelmer » 02 Nov 2019, 00:12

Hi Kevin,

Thanks for your try on this, it seems to be a quite entangled issue. In my simple-minded user's view 8-) , I still hope it is not too much work for someone to update the code for the convergence monitor to using the current version qt/qwt commands... as it is "just" an auxiliary module...

I appreciate the support;
Thomas.

kevinarden
Posts: 290
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Missing convergence view in ElmerGUI

Post by kevinarden » 02 Nov 2019, 01:20

One option is that they produce an Virtual Machine with everything Elmer already installed and working.

http://www.nic.funet.fi/pub/sci/physics ... lMachines/

kevinarden
Posts: 290
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Missing convergence view in ElmerGUI

Post by kevinarden » 05 Nov 2019, 01:58

Since the Elmer VM is Linux Mint 18.3 I did some testing using virtualbox.

Using Mint 18.3 which is based on UBUNTU 16.04
sudo apt-get install elmerfem-csc
installs Elmer and ElmerGUI and the convergence window is present

0n Mint 19.3 based on UBUNTU 18.04
sudo apt-get install elmerfem-csc
installs ElmerSolver but not ElmerGUI

sudo apt-get install elmerfem-csc-eg
installs Elmer and ElmerGUI but there is no convergence window.

kevinarden
Posts: 290
Joined: 25 Jan 2019, 01:28
Antispam: Yes

Re: Missing convergence view in ElmerGUI

Post by kevinarden » 05 Nov 2019, 12:20

Continued test using UBUNTU

Using UBUNTU 16.04
sudo apt-get install elmerfem-csc
installs Elmer and ElmerGUI and the convergence window is present

Using UBUNTU 18.04
sudo apt-get install elmerfem-csc-eg
installs Elmer and ElmerGUI but there is no convergence window.

Using UBUNTU 19.1
No Elmer packages

Used Peppermint 10 which is a light OS, xfce, based on UBUNTU 16.04, works and it is a very fast VM for the OS could hardly tell it was a VM. UBUNTU 19 was very slow.

Post Reply