Elmer crash when clicking on boundaries

Clearly defined bug reports and their fixes
Post Reply
Roland
Posts: 11
Joined: 12 Apr 2018, 11:29
Antispam: Yes

Elmer crash when clicking on boundaries

Post by Roland » 05 Jul 2018, 11:04

Hi,
I have downloaded Elmer 8.3-98dec6e6 version.
The loading of a project works, but when clicking on a boundary for setting the boundary conditions, it does not turn the selected boundary in red color, the "set boundary properties" box opens partially and after a few seconds Elmer crashes and closes.
Has anybody the same problem and is there an idea for fixing this bug?
Thanks for your help.
Roland

raback
Site Admin
Posts: 3277
Joined: 22 Aug 2009, 11:57
Antispam: Yes
Location: Espoo, Finland
Contact:

Re: Elmer crash when clicking on boundaries

Post by raback » 08 Jul 2018, 18:06

Hi Roland,

Does the problem related only to a case that is reloaded, or also to some cases where you start from the mesh description only?

I just opened some mesh/CAD files with a fresh Windows version (wire.grd and pump_carter_sup.stp) and can select entities there. Could the problem lie in restarting from files generated by a previous version?

-Peter

schweb
Posts: 1
Joined: 09 Dec 2012, 04:32
Antispam: Yes

Re: Elmer crash when clicking on boundaries

Post by schweb » 23 Aug 2018, 04:33

Hi Roland,

I have exactly the same problem.
In detail I have installed the software, 8.2 and 8.3 on my personal laptop and works perfectly.
The other computer I use is at work where both versions show the same double click problem as you mentioned.

Is a solution available as yet?

Both computers have Win10 64-bit.
I tried many things without a successful outcome, such as:

1- run compatibility mode to win7.
2- reboot after installation
3- check firewall and antivirus
4- run as admin
5- run windows troubleshooting
6- import a simpler geometry file, like a block.
7- change project directory to C:\a\ to avoid spaces in the path etc.
8- changed Elmer's root directory to C:\Elmer8.3-c30fff2\bin (no spaces) and updated environment variables.

Help! :)

Thanks in advance

Regards
Schweb

Phlix
Posts: 1
Joined: 31 Aug 2018, 13:51
Antispam: Yes

Re: Elmer crash when clicking on boundaries

Post by Phlix » 18 Sep 2018, 16:57

Hi,

I have the same problem.
When I installed Elmer 8.3-98dec6e6 a few weeks ago everything was working regarding this topic.
(I conducted the wire tutorial and similar simulations)

I did not do an Update or anything related. Out of nowhere this error occurred.

Now I reinstalled Elmer, downloaded the newest modified version (elmerfem-nightly_Windows-AMD64.exe 12-Sep-2018 00:33 84M)
but still Elmer crashes if the boundaries are selected manually.
I tried several projects and in all it's the same :(

Sometimes when I hit a boundary (before Elmer crashes) in the lower left corner of ElmerGUI the string "Error: Boundary Index mismatch" occours.

Is there any known reason for this error? Or even a solution?

Best regards,

Phlix

mzenker
Posts: 1747
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Elmer crash when clicking on boundaries

Post by mzenker » 18 Sep 2018, 17:28

Hi,

AFAIR the boundary selection in 3D has never worked correctly in ElmerGUI. There is no real solution for that, except fix the bug in the code...
The problem is that ElmerGUI is not really actively maintained, since the Elmer team has limited (wo)manpower and concentrates on the FEM engine, i.e. the solver.
So if there is a C++ hero out there who wants to devote some time, (s)he is free to get the code and fix it... ;)

There is kind of a workaround to find out the boundary number for 3D meshes: do it outside ElmerGUI using gmsh. Here is how to do it: When the mesh is imported in ElmerGUI, do "save project". Then go to the project directory with a command line terminal (DOS box in Windoze) and say

ElmerGrid 2 4 mesh

This will generate a file mesh.msh which can be opened in gmsh and has the same numbering as the Elmer mesh. In gmsh you can view the mesh and find out the boundary numbers much more comfortably than in ElmerGUI.

HTH,
Matthias

Post Reply