Elmer8 gives zero results for electric field

Clearly defined bug reports and their fixes

Elmer8 gives zero results for electric field

Postby mzenker » 01 Mar 2016, 19:30

Hi,

I am afraid there is a problem in Elmer8. When I calculate an electric field using the electrostatics solver, I get a zero result. Running the exact same sif and mesh with Elmer7 gives the correct result. I attach a testcase for inspection. As long as that one is not understood, I will stay on Elmer7 and advise everyone to do the same.
Elmer8 binary nightly build 2016/02/26, Windows 7.

Matthias

P.S.: This was a bit terse - sorry for that. I am in a project where I need the results...
Attachments
Elmer8_Electrostatic_bug.zip
(64 KiB) Downloaded 75 times
mzenker
 
Posts: 1596
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Elmer8 gives zero results for electric field

Postby raback » 02 Mar 2016, 02:55

Hi Matthias,

I think that the electric field was never computed properly. It was simply an average of gradient over the elements. Also the implementation based on the simple summation was not parallel. Thus, it may be that the not-so-good strategy was eliminated. I would rather recommend using FluxSolver which uses proper FEM techniques that also work in parallel. We should maybe reimplement computation of electric field properly within the solver.

-Peter
raback
Site Admin
 
Posts: 3124
Joined: 22 Aug 2009, 11:57
Location: Espoo, Finland

Re: Elmer8 gives zero results for electric field

Postby mzenker » 02 Mar 2016, 12:17

Hi Peter,

just to make sure that I understood correctly: You recommend not to use the StatElec Solver to calculate the electrostatic field??
I am surprised...
If I further understand correctly, I should then calculate the potential and use the FluxSolver to calculate the gradient?
Would it make a difference which one of StatCurrent and StatElec Solver I use to calculate the potential?

Thanks,

Matthias
mzenker
 
Posts: 1596
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Elmer8 gives zero results for electric field

Postby raback » 02 Mar 2016, 12:45

Hi Matthias

StatCurrentSolver and StatElecSolver are mathematically quite the same but the 1st is for conductors and the 2nd one for insulators. With both you can use FluxSolver to compute the field and the fluxes. It is not perhaps optimal, and restoring proper flux computation within those solvers would be desirable. Computing the fluxes / gradients is basically just postprocessing since the result of the Poisson equations is just the potential.

-Peter
raback
Site Admin
 
Posts: 3124
Joined: 22 Aug 2009, 11:57
Location: Espoo, Finland

Re: Elmer8 gives zero results for electric field

Postby mzenker » 02 Mar 2016, 13:34

You are right - so I will go for StatCurrent and use the Gradient filter in ParaView. That is fine for my purpose.
But I hope the field calculation will be repaired anyway - after all, it is a functionality of the StatElec Solver which is described in the manual, so people assume that it will work that way...

Thank you,

Matthias
mzenker
 
Posts: 1596
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Elmer8 gives zero results for electric field

Postby Wil » 02 Jul 2016, 22:33

Hallo Matthias,
is it possible that you provide a simple example how you set up such a model and how you apply the gradient filter in paraview?

I have built a simple cube with two potentials on two opposite boundaries. I could calculate the potential distribution but I could not apply a gradient filter in paraview.
The filter is grayed out.
Thank you very much in advance,
HoWil
Wil
 
Posts: 57
Joined: 10 Jan 2014, 13:26
Location: Austria

Re: Elmer8 gives zero results for electric field

Postby mzenker » 04 Jul 2016, 11:15

Hi,

you can use the "Gradient for unstructured dataset" filter in ParaView. Don't know why the other one is greyed out.
If you want to do it within Elmer, just activate the FluxSolver to be executed "after simulation" (for steady state). In ElmerGUI, if you use the Resultoutput solver also "after simulation", you have to give execution priority 1 to the FluxSolver.

HTH,

Matthias
mzenker
 
Posts: 1596
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Elmer8 gives zero results for electric field

Postby axjjienn » 11 Aug 2017, 02:13

Hello!

I just wanted to check if this is still an issue in Elmer 8.3? I am doing some simple 2D explorations with open air capacitive plates, and so far the results look good (as in, they make good plots). However I am concerned that when running simply the electrostatic module (with capacitive solving on) that there is some thing very wrong with the accuracy of the results. The electric field seems to be going the wrong way, and the potential doesn't match the Boundary conditions. I have attached my sif file.

Please let me know if there is additional information which might help, or if I should be using the electrostatic solver coupled with the flux solver (and what the right way to couple them might be)

-Alejandro
Attachments
case1b.sif
(2.34 KiB) Downloaded 9 times
axjjienn
 
Posts: 4
Joined: 10 Aug 2017, 23:45
Location: San Francisco, CA USA

Re: Elmer8 gives zero results for electric field

Postby mzenker » 11 Aug 2017, 11:04

Hi,

difficult to say something without knowing the geometry.
Two remarks nevertheless:
1. why do you need the inifinity BC?
2. what happens if you set the potential BC to +4000 and 0 instead of +2000 and -2000?

HTH,

Matthias
mzenker
 
Posts: 1596
Joined: 07 Dec 2009, 11:49
Location: Germany

Re: Elmer8 gives zero results for electric field

Postby axjjienn » 12 Aug 2017, 01:49

Hey Matthais,

1.) I am accustomed to needing an infinite boundary from other EM-FEM software I have used (ANSYS) that become numerically unstable without it. If you think the problem is well posed without it, I can give it a try, but I don't imagine that is the source of my problems.

2.) I wasn't sure if a negative BC could be the problem so I re-ran it with the ground (0 potential) and 4kV potential on the other plate, and changing the number of excited capacitive bodies to 1. When I run that, the electric field direction looks right, but is non-symmetric.

However, when I run the original case without solving for capacitance, the field direction is correct, but the strength of the field outside the plates seems dubious.

I guess I am curious what is the bes practice to capture the physics appropriately of a series of charged plates.

Should I use the Flux solver instead of checking the electric field box in the ES solver options?

Would going into 3D and using the static current solver coupled with the ES solver, or on its own, be more accurate?

regards,

Alejandro
Attachments
geom.tar
Geometry.
(1.92 MiB) Downloaded 6 times
axjjienn
 
Posts: 4
Joined: 10 Aug 2017, 23:45
Location: San Francisco, CA USA

Next

Return to Bug reports

Who is online

Users browsing this forum: No registered users and 3 guests