Search found 74 matches

by kataja
12 Aug 2016, 17:31
Forum: ElmerSolver
Topic: Elmer Magnetics 3D comparison with 2D Axisymmetric Lumpy
Replies: 30
Views: 8884

Re: Elmer Magnetics 3D comparison with 2D Axisymmetric Lumpy

Hi! I don't think its fruitful to compare the vector potential because its not unique even though its integrals over surface edges are. For the "discontinuous bodies" keyword to take effect, you should investigate the variable "Magnetic Flux Density e" instead of "magnetic flux density" (in solver 3...
by kataja
15 Jul 2016, 15:40
Forum: ElmerSolver
Topic: [SOLVED] MagnetoDynamics WhitneyAV: zero electric field
Replies: 1
Views: 1073

Re: MagnetoDynamics WhitneyAV: zero electric field and current

Nothing. There was a bug in MagnetoDynamicsCalcFields (the post processing solver) that caused the electric field to become zero. It's fixed in latest devel version in the github (e69732a).

Thanks!
Juhani
by kataja
02 May 2016, 10:28
Forum: Installation & compilation
Topic: Installation on ubuntu 16.04 LTS
Replies: 13
Views: 10528

Re: Installation on ubuntu 16.04 LTS

For some reason, the shared objects are not found in Ubuntu 16.04 using RPATH. Workaround for this should be (assuming bash): $ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/elmersolver or $ export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib/elmersolver $ ElmerGUI depending where the shared o...
by kataja
27 Apr 2016, 17:32
Forum: ElmerSolver
Topic: Magnetodynamics Solver, wrong magnetic field strength?
Replies: 2
Views: 1469

Re: Magnetodynamics Solver, wrong magnetic field strength?

Hi I think you might be missing a keyword "electric current density" on the wire ends (BCs 1 and 2) that is used to tell the AV solver what should be the current at the boundary. If its not given, the Helmholtz projected input current might look unexpected (see around pp. 86 in the Elmer Models Manu...
by kataja
27 Apr 2016, 17:22
Forum: Installation & compilation
Topic: Error Messages when loading GUI
Replies: 5
Views: 3197

Re: Error Messages when loading GUI

Hi!

Apparently ElmerGUI uses variable ELMERGUI_HOME and it should point to "C:\Program Files (x86)\Elmer 8.0-Release\share\ElmerGUI".

-Juhani
by kataja
21 Mar 2016, 14:19
Forum: Installation & compilation
Topic: Apple OS X 10.11.3 installation ctest failures
Replies: 5
Views: 2943

Re: Apple OS X 10.11.3 installation ctest failures

Hi! In my experience the OS X's Accelerate framework does not work with elmer. Instead I'd suggest using OpenBLAS (www.openblas.net) or reference blas/lapack for blas and lapack library. OpenBLAS installed with homebrew should work so long as you provide cmake with variables "BLAS_LIBRARIES" and "LA...
by kataja
22 Feb 2016, 10:14
Forum: Installation & compilation
Topic: Installation Error Microsoft Visual C++ 2010 Redistributable
Replies: 3
Views: 3487

Re: Installation Error Microsoft Visual C++ 2010 Redistributable

Hi!

The error messages just indicate that a newer (or same) version of MS Visual C++ 2010 Redistributable and MS MPI libraries are installed. This is likely because of earlier installation of Elmer and if that is the case, these error messages should not indicate of any serious issue.

Cheers,
Juhani
by kataja
16 Feb 2016, 16:40
Forum: ElmerSolver
Topic: S-Parameters, VectorHelmholtz Tutorial
Replies: 3
Views: 1286

Re: S-Parameters, VectorHelmholtz Tutorial

Hi! Apparently, there is an error of size "-1/mu" in the formula for l(E) appearing in the VectorHelmholtz tutorial (pp. 73). The permeability and the minus sign in the Eq. (15.6) in the Elmer Models manual is not taken into account when deriving to the formula for l(E) in the tutorial. Correct form...
by kataja
03 Feb 2016, 20:01
Forum: ElmerSolver
Topic: problem with energy functional value
Replies: 2
Views: 1234

Re: problem with energy functional value

Hi, it's strange that the energy functional value doesn't change. It should. it looks like you are modeling waveguide port feed assuming near vacuum material near the input port while the actual material is something with relative permittivity greater than 9. Does the field solution look different i...
by kataja
16 Dec 2015, 17:31
Forum: Installation & compilation
Topic: Elmer 8.1 under Windows: Solver dlls not found
Replies: 5
Views: 3740

Re: Elmer 8.1 under Windows: Solver dlls not found

Hello, Thank you for finding and reporting this bug! A workaround to this bug might be: only set ELMER_HOME to e.g. "C:\ProgrammePlus\Elmer 8.1-Release" make sure that PATH variable contains %ELMER_HOME%\bin unset all other elmer related environment variables such as ELMER_LIB Anyhow, the bug is fix...