Search found 54 matches

by mal
28 Sep 2009, 08:46
Forum: Installation & compilation
Topic: Compiling Tetgen
Replies: 15
Views: 8715

Re: Compiling Tetgen

ahmed@debian:~$ cd elmer ahmed@debian:~/elmer$ ./a.out Loads fine ahmed@debian:~/elmer$ please note that the elmer folder is a work folder where I have copied the samples and tutorials, the Elmer programme itself is saved in its standard location. Any clues or hints are highly appreciated Based on ...
by mal
27 Sep 2009, 21:05
Forum: ElmerGUI
Topic: MPI error on Tutorial
Replies: 4
Views: 4740

Re: MPI error on Tutorial

Hi,

Could you please try unlimiting the stack size with "ulimit -s unlimited" before launching ElmerGUI?

Does your model complete with the serial solver?
by mal
27 Sep 2009, 11:49
Forum: Installation & compilation
Topic: Compiling Tetgen
Replies: 15
Views: 8715

Re: Compiling Tetgen

Ok. Could you please run the following small diagnostics utility? Compile and run it as "g++ test.cpp -ldl && ./a.out" #include <iostream> #include <dlfcn.h> int main() { void *h; if(!(h = dlopen("libtet.so", RTLD_LAZY))) { std::cerr << dlerror() << std::endl; return 0; } if(!dlsym(h, "CreateObjectO...
by mal
26 Sep 2009, 17:31
Forum: Installation & compilation
Topic: Compiling Elmer with MPI
Replies: 23
Views: 13631

Re: Compiling Elmer with MPI

Are you able to run simple MPI programs with your setup?

Check also the -envall switch from mpich user guide.
by mal
26 Sep 2009, 11:57
Forum: Installation & compilation
Topic: Compiling Tetgen
Replies: 15
Views: 8715

Re: Compiling Tetgen

Are you using tetgen 1.4.2?

The new version 1.4.3 from september 2009 has introduced some changes, which make it incompatible with the current version of ElmerGUI.
by mal
25 Sep 2009, 18:46
Forum: Installation & compilation
Topic: Compiling Elmer with MPI
Replies: 23
Views: 13631

Re: Compiling Elmer with MPI

The difference between trunk and release is in the ISO_VARYING_STRING module. This module has caused some problems with older compilers like gfortran <= 4.1.

Unfortunately I cannot check your issue, since I do not have access to pathscale 2.2. All I can say it compiles with 2.5, 3.0, 3.1 and 3.2.
by mal
25 Sep 2009, 10:43
Forum: Installation & compilation
Topic: Compiling Elmer with MPI
Replies: 23
Views: 13631

Re: Compiling Elmer with MPI

What says "mpif90 -show"? Does it compile MPI sample programs?

You might also want to manually inspect the dependencies of your mpi lib by typing "ldd libmpich.so".

Finally, try adding the switch "--with-mpi-dir=/path/to/my/mpi" to the configuration script.
by mal
24 Sep 2009, 20:14
Forum: Installation & compilation
Topic: Compiling Elmer with MPI
Replies: 23
Views: 13631

Re: Compiling Elmer with MPI

One more thing. Have you checked whether your mpich installation provides MPI-specific wrappers for your compilers? Usually these wrappers are called mpicc, mpic++, mpif90, or something similar. It might be a good idea to use these instead of the plain compiler commands, they should automatically se...
by mal
24 Sep 2009, 17:34
Forum: Installation & compilation
Topic: Compiling Elmer with MPI
Replies: 23
Views: 13631

Re: Compiling Elmer with MPI

Hi,

If you want to pass a specific library path to the linker, you can use the LDFLAGS variable, e.g. export LDFLAGS=-L/some/path

LD_LIBRARY_PATH is related to runtime loading of shared libraries.
by mal
23 Sep 2009, 19:32
Forum: Installation & compilation
Topic: Compiling Elmer with MPI
Replies: 23
Views: 13631

Re: Compiling Elmer with MPI

Ok. /opt/mpich2/lib/libmpich.a(allreduce.o): In function `MPIR_Allreduce_inter': allreduce.c:(.text+0x1c7): undefined reference to `pthread_getspecific' It seems that the linker is unable to find `pthread_getspecific' and other functions related to pthreads. So, I'd try adding -lpthread to LIBS befo...