Search found 34 matches

by KaiMartin
28 Jul 2018, 13:49
Forum: Installation & compilation
Topic: ElmerGUI command not found
Replies: 18
Views: 3846

Re: ElmerGUI command not found

cosinus@Rechner001:~$ elmerGui elmerGui: Befehl nicht gefunden. That means: ElmerGUI command not found. It means 'elmerGUI' not found. You may try 'ElmerGUI'. I.e. with a capital E. Linux is case sensitive. If the command is still not found, you can check with the search tool 'locate'. If it isn't ...
by KaiMartin
28 Jul 2018, 02:50
Forum: Installation & compilation
Topic: Build report on Debian testing, summer 2018
Replies: 7
Views: 1785

Re: Build report on Debian testing, summer 2018

How were you able to pull libvtk5-qt4-dev and libvtk5-dev? When I try to install them (Debian Stretch) I wind up with unresolvable dependencies. I used aptitude rather than apt-get. This utility works on the same set of packages but differs in the way it handles conflicts. If it does not succeed st...
by KaiMartin
24 Jul 2018, 05:29
Forum: Installation & compilation
Topic: Build report on Debian testing, summer 2018
Replies: 7
Views: 1785

Re: Build report on Debian testing, summer 2018

Thank you so much for posting this info, it was exactly what I needed to get Elmer running on my Debian system! You are welcome. Did your install automatically pull in Tetgen support (assuming the packages were already installed) or was it an option for cmake? I seem to remember that cmake reported...
by KaiMartin
19 Jul 2018, 04:30
Forum: Installation & compilation
Topic: Build report on Debian testing, summer 2018
Replies: 7
Views: 1785

Re: Build report on Debian testing, summer 2018

If I try WITH__MKL configure fails with CMake Error at cmake/Modules/FindMKL.cmake:242 (MESSAGE): Call Stack (most recent call first): CMakeLists.txt:138 (FIND_PACKAGE) The error log contains: Determining if the pthread_create exist failed with the following output: Change Dir: /usr/local/src/elmer_...
by KaiMartin
16 Jul 2018, 03:46
Forum: Installation & compilation
Topic: Build report on Debian testing, summer 2018
Replies: 7
Views: 1785

Re: Build report on Debian testing, summer 2018

If I try to compile with hypre cmake fails to find the library even though I have the packages libhypre-dev and libhypre-2.14.0 installed. Configure complains: CMake Error at cmake/Modules/FindPackageHandleStandardArgs.cmake:108 (message): Could NOT find Hypre (missing: Hypre_INCLUDE_DIR) Call Stack...
by KaiMartin
15 Jul 2018, 17:16
Forum: Installation & compilation
Topic: Build report on Debian testing, summer 2018
Replies: 7
Views: 1785

Re: Build report on Debian testing, summer 2018

This is the error log I got when I tried the option WITH_MATC : $ make -j 4 ... [ 82%] Building CXX object ElmerGUI/Application/CMakeFiles/ElmerGUI.dir/ElmerGUI_autogen/mocs_compilation.cpp.o In file included from /usr/lib/x86_64-linux-gnu/oce-0.17/../../../include/oce/gp_Trsf2d.hxx:243:0, from /usr...
by KaiMartin
15 Jul 2018, 07:07
Forum: ElmerGUI
Topic: error runing my first model
Replies: 4
Views: 1065

Re: error runing my first model

Can you post the *.sif file? This is a compilation of the settings you did in the GUI. It is used an input for the solver.

---<)kaimartin(>---
by KaiMartin
13 Jul 2018, 06:08
Forum: Installation & compilation
Topic: Build report on Debian testing, summer 2018
Replies: 7
Views: 1785

Build report on Debian testing, summer 2018

With a shiny new PC I decided to give a build of elmer a fresh try. OS is Debian testing/buster last updated in June 2018. I used cmake-gui to choose build options: $ git clone https://github.com/ElmerCSC/elmerfem elmerfem $ cd elmerfem $ git checkout origin/devel $ cmake-gui CMakeCache.txt --> chec...
by KaiMartin
13 Jul 2018, 05:18
Forum: Installation & compilation
Topic: Elmer Ubuntu Virtual Machine
Replies: 6
Views: 5031

Re: Elmer Ubuntu Virtual Machine

minhaj021 wrote:
15 May 2018, 12:19
I want to install openpyxl using VM but its giving the following errorVM openpyxl error.PNG.
openpyxel does not seem to be needed by elmer.

---<)kaimartin(>---
by KaiMartin
13 Jul 2018, 05:15
Forum: Installation & compilation
Topic: Adding OCC, Trilinos or mumps Elmer wont build
Replies: 3
Views: 1393

Re: Adding OCC, Trilinos or mumps Elmer wont build

For the OCC build error: install the package liboce-modeling-dev For the trilinos build error: install the package libtrilinos-epetra-dev This is how I resolve these kind of errors: I search for the missing file in the debian repositories with the tool apt-file. You may have to install the package a...