Search found 11 matches

by wing
12 Aug 2020, 17:35
Forum: Installation & compilation
Topic: Compiling Elmer FEM using CMake under Ubuntu 20.04.1 LTS
Replies: 5
Views: 712

Re: Compiling Elmer FEM using CMake under Ubuntu 20.04.1 LTS

Hi Kumar, You have to install required libraries and header files before you can build Elmer. sudo apt-get install libblas-dev will do the job for you. But for your Ubuntu is a fresh installation you may have to repeat the try and error process because there could be more packages to install. Actual...
by wing
27 Apr 2016, 17:07
Forum: Installation & compilation
Topic: Error Messages when loading GUI
Replies: 5
Views: 4161

Re: Error Messages when loading GUI

I had the same ERROR:: InitializeElementDescriptions: elements.def not found problem recently and I confirmed that set ELMER_HOME to installation directory ($HOME/Apps/elmer in my case) solved the problem. P.S. UBUNTU 16.04 64 bit, Elmersolver git Version: 8.2 (Rev: a095b95, Compiled: 2016-04-23) an...
by wing
14 Nov 2009, 11:37
Forum: ElmerSolver
Topic: problem in tutorial 1 (norm of solution)
Replies: 1
Views: 1581

problem in tutorial 1 (norm of solution)

Hello everybody, I tried Tutorial 1 (Heat Equation - Temperature field of a solid object) which use pump_carter_sub.stp according to ElmerTutorials.pdf (September 22, 2009). I found that the norm of my solution is about 432.4, but it says it should be around 389.853 in the ElmerTutorials.pdf (page 9...
by wing
13 Nov 2009, 17:37
Forum: Installation & compilation
Topic: Problem configuring Front and Post
Replies: 3
Views: 2581

Re: Problem configuring Front and Post

Hi akredd,
Do you install from a binary package or do you compile from source code?
I'm running a x86_64 Linux with tcltk8.5 too and I can compile ElmerPost from source. Not sure about ElmerFront because I use ElmerGUI instead.
Good luck.

wing
by wing
13 Nov 2009, 14:56
Forum: ElmerGUI
Topic: sif file from ElmerGui : bug
Replies: 7
Views: 4120

Re: sif file from ElmerGui : bug

Hi there, I have similar 'overwrite' issue here. When I generate the .sif file from ElmerGUI and do some modification manually, it only works for the current session. That is to say, after I close ElmerGUI, launch it again and load the project, the .sif was overwritten (back to the original one gene...
by wing
12 Nov 2009, 08:40
Forum: ElmerGUI
Topic: Python interface missed?
Replies: 2
Views: 2427

Re: Python interface missed?

mal,

Sorry, my fault. When read in 7.3.1 of ElmerGUI manual I thought the Edit -> PythonQt console ... is under ElmerGUI main window but actually it should be under the location you mentioned.
It's there and thank you for your mention.

wing
by wing
11 Nov 2009, 11:47
Forum: ElmerGUI
Topic: Python interface missed?
Replies: 2
Views: 2427

Python interface missed?

Hello forum, I am a bit confused with my compilation of ElmerGUI with PythonQt support and hope I can get some information here. (I thought) my ElmerGUI was compiled with PythonQt, but I cannot find out where to launch the Python console. I have no Edit-menu in my ElmerGUI. libPythonQt.a was generat...
by wing
30 Oct 2009, 18:17
Forum: Installation & compilation
Topic: Tetgen_plugin compilation error, 64bit
Replies: 2
Views: 2658

Re: Tetgen_plugin compilation error, 64bit

Please do "svn update" and recompile the plugin. Thanks mal. compiled after svn-update and the same error occurred. Finally it is solved after some modification of plugin/Makefile file. wing@liuyj-n:~/software/elmer-svn/trunk/misc/tetgen_plugin/plugin$ diff Makefile Makefile.bak 14,15c14,15 < CFLAG...
by wing
29 Oct 2009, 18:40
Forum: Installation & compilation
Topic: Tetgen_plugin compilation error, 64bit
Replies: 2
Views: 2658

Tetgen_plugin compilation error, 64bit

Hi forum, I compiled Elmer (64bit) successfully and it runs well. But when I tried to compile tetgen plugin for ElmrGUI I got the error below. /usr/bin/ld: predicates.o: relocation R_X86_64_32 against `__gxx_personality_v0' can not be used when making a shared object; recompile with -fPIC predicates...
by wing
18 Oct 2009, 11:51
Forum: ElmerGUI
Topic: ugly mesh and remesh doesn't work
Replies: 5
Views: 4126

Re: ugly mesh and remesh doesn't work

Hi mal,

Thanks for your response. It works for me.